My phone has no Internet at all

My phone (an Android Moto G4) is currently on my home WiFi, and can’t connect to the Internet. The WiFi itself is working, because one of my computers has no network cables going into it, only a WiFi connection, and it’s still able to connect. But, shrug, maybe there’s something wrong with the WiFi on my phone, so I tried turning it off and falling back on the 3G. And that doesn’t work, either. Both the WiFi and 3G are showing good signal strength, but both have exclamation points next to them (but I can’t find any explanation of what problem they’re finding). When I try to load a web page, Chrome gives me the error message “DNS_PROBE_FINISHED_NO_INTERNET”. When I try loading , I get the message

What could be causing this problem?

Try rebooting your router and modem.

Did you accidentally put your phone in airplane mode, by chance?

When I was a young’un, none of our phones had internet. And we liked it that way!

Maybe too obvious, but: Have you tried powering the phone off and back on?

If the computer is connecting to WIFI, but your phone isn’t, then I can’t see how it could be a router/modem problem. The problem must be with your phone. My phone does this from time to time & what has fixed the problem is to toggle everything off then back on–Go to settings & toggle WIFI off/on; same for airplane mode; then turn phone off & on again & see if that fixes it.

The router and modem aren’t the problem, because as I said, other devices on the network are fine, and that wouldn’t explain the 3G being down, too.

And I just double-checked, and it’s not in airplane mode.

Thudlow, maybe it was too obvious, but turning the phone off and back on again did in fact fix it. But I’d still like to know why.

My iPhone does this from time to time & it was explained to me at the Genius Bar that powering the phone off & back on (or toggling the WIFI settings off & on) reestablishes the “handshake”. The handshake, I was told, establishes the protocols with the communication link & if something is off, then powering off/on gets it back on track.

I’m sure I did a horrible job of explaining that and maybe some techy person will chime to explain it properly.

Get used to disappointment.


There’s just so many things that can get hung or crash that it’s not really worth debugging unless it happens repeatedly. A reboot just restarts everything from a known good state.

Repeatedly? Apparently, Boeing only requires two.

And the phone if you haven’t already.

FWIW, is the address of Google DNS.

Is it just Chrome not working on your phone, have you tried other apps that use internet?

That’s a good question that I should have thought to test before I rebooted (which fixed it).

Too soon, maybe?

Sometimes when Mrs. Plant (v.3.0) is watching video on the web, I must turn wireless off and back on for my Dell laptop to access the web.

I should mention that my Windows desktop computer, which connects via the WiFi, does fall off of it somehow every few days, and needs to be rebooted before it works again. But that still wouldn’t account for the 3G failing at the same time.

If some buffer were really full (I have seen this “sendto: No buffer space available” error before on a computer running BSD; still no idea what precisely caused it, but deleting and recreating the wireless interface worked), then it could affect the 3G data connection as well. It is a software, not a hardware, problem.