Smart phone users: Any luck going through a wi-fi network to the Web?

(Note, I’ve asked this question on other message boards specific to Android, but haven’t gotten any useful answers.)

I don’t know if it’s a universal feature with smart phones. But the ones that I’ve had both were allegedly capable of working over a typical WLAN with Web access. I think this could be particularly useful in some cases; for instance, if your carrier’s coverage isn’t that great wherever you are right now, you’d still be able to get connected if you have access to a nearby WLAN. You wouldn’t be able to make calls, but at least you could still read your email, use Google Maps, and what have you. I just changed carriers and mobile devices, and thought this would be useful, particularly since the old phone has a significantly better camera.

So I got out my old HTC, went to Settings–>Communications–>Enable Wi-Fi, and changed it to Enabled. But it doesn’t work. I’ve tried it with my home network, and at two or three coffee shops, and the browser (Opera) always times out. I thought maybe there was some sort of black magic on AT&T’s part that prevents the device from being used in any way whatsover when there’s no active contract. Strangely enough, though, the result with my new LG is the same. Whatever browser I use times out if I try to use it over a WLAN. As far as the infrastructure is concerned, neither my home WLAN nor the ones I see in public settings are particularly good, we’re talking middling slow DSL here. 1.5 Mbps is what my ISP’s SLA provides for, and Web access is noticeably slower in typical public settings, like coffee shops. As limited as these throughput levels might seem, they are adequate for nearly all of my needs, and would seem more than capable enough of supplying connectivity to a 3G smart phone.

But I’ve never been able to make this work. No matter which phone I try, the browser times out. Is there something else I need to adjust?

I use my iPhone on WiFi all the time.

Yes, all the time, on multiple iPhones, Android phones and one Blackberry. My current iPhone is on wifi whenever I’m at home or at work.

Yeah, I’ve rarely had problems connecting to Wi-Fi on Android. What version are you running?

Are you actually connecting to the network? Do you see the wi-fi symbol on your phone?
What do you see when you go to Settings->Wireless and Networks->Wi-Fi Settings? Do you see your network listed? Does it show you connected to your network?

ETA: just enabling wi-fi doesn’t actually do anything but make a connection possible. Do you have a password on your network?

I’m running Android 2.2, and yes, I’m logging into my home WLAN. This requires a 10-digit security passcode and I am able log on, but after that nothing works. Away from home, my computer or device generally has to first be able to download a splash page from the local network, for example at Starbucks where you check the box to agree with their terms of use. In this scenario I don’t get as far as filling in the check box because the splash page won’t load.

I should say these public networks usually aren’t terrifically fast, but with my notebook are adequate for most typical demands at least up to and including audio streaming.

I’ve never had a problem using the Internet over a WIFI connection with my Android phone (a Motorola Droid X). In fact, it’s my preferred way of accessing the Internet because it’s faster than my 3G connection.

You might try downloading one of the many free WIFI managers available via the Android Market, as they typically give you more/better information about your WIFI connection than the standeard WIFI manager will. I’m currently using and am happy with “WIFI Manager” by Kosta Vasilyev, but there are undoubtedly better ones out there.

Yup. For years.

Sounds like it’s something I need to check out. I hope there’s something similar for my old WinMo device, but I wouldn’t stake a French-fry on that.

I use my iPhone on home and work networks every day, and my Sidekick before that.

Yep…should work fine.

Specrte, what happens if you turn off the cellular (GSM/CDMA/…) radio, and ONLY have WiFi enabled? Obviously not a solution, but it’s what we in the cell phone business call “an interesting data point.” :slight_smile:

It’s not enough to just turn on the WiFi radio, you have to then go to a screen that shows available networks and connect to one. Or did you actually do that and just not mention it in your post? What OS is your phone running?

Are you getting an IP address? 10 digit security code sounds like AT&T. Is AT&T your ISP? Can you see your phone on the gateway after you logon?

That isn’t how my wifi is set up on any of my devices (two iPhones, a PS3, and a PSP). They all detect my network, which is connected to Comcast, not AT&T, and uses a ten digit encryption key which is set into my router. To connect any of mine, which I only need to do one time, is select my network and enter the ten digit key. There are no ISP or gateway settings involved. They simply detect my router. I suspect Spectre’s setup and phone are very similar. He says he can connect, but his phone runs slowly on wifi no matter what he is connected to.

Edit - That 10 digit key should be the 64 bit WEP encryption key on his router to prevent unauthorized use of his signal. It is on mine, anyway.

First of all, thanks to all who have responded. As you’ll see, I’ve already got wi-fi working on my new device.

cochrane, IIRC my home WLAN is “unsecured”, but does require the 10-digit code to access it.

sevenwood, I did try downloading a wi-fi manager on the LG (Android OS) device, and it worked like a charm. Downloads are almost as fast as with my notebook, uploads considerably slower but I can’t see how that’ll be much of an issue anyhow. Now if I could just find a similar tool for the old HTC I’d be all set. Since right now the HTC is blind to the world, this would have to be something I can download on my PC, and then transfer to the HTC via USB cable.

DITNA, how do I turn off the “radio” you mention? I assume the wi-fi manager on the Droid is doing that for me so it’s not an issue there. Am I wrong in supposing that if I learn how to do this on the HTC it would probably solve my issue on that device as well?

As noted I no longer have this issue with the Android phone.

The older phone is an HTC running Windows Mobile Professional 6.5; my carrier used to be AT&T. My home ISP is also AT&T via the land line, and yes, I do log into the network, typing in the security code.

I know it’s possible to run Android on the old device, but I’m still much too much of a noob to make that happen.

Not sure if it’ll help with the HTC or not. It’s just something to try.
The last WM phone I used was 6.1. I don’t remember the menu options off hand, but there should be something about network connectivity or similar in the same general area as the Settings->Communication menu you were in already.

I’m doing a good bit of cleaning at the house right now. If I come across one of the old phones, I’ll power it up and see if I can find an option…although I think I have non-WiFi software on the ones I have handy. We never actually shipped the WiFi version of the one I worked on. The menus may be a little different because of this.

CAN YOU TALK with telephone using the WiFi connection? I heard iPhones can do this, and iPod Touches. It sounds plausible because it’s all digital and there are other phones that use IP. I hope I might be able to do this when I get an iPhone (I hope) next month, as cellular signals at my house are very weak. If it matters, I do have VOIP telephone in my house now (though I think that means a special modem with a phone jack on it, which I guess would be irrelevant for a cellphone).

I have an iPhone 4, and I’m pretty sure that you can only use FaceTime (video phone) with other iPhone users over WiFi, not actual phone calls. I have a terrible time sending text messages in my office because the phone signal is crap there, even with a great WiFi connection.