Can't get my TV to display my PS3 in 1080p

For some reason, I can’t get my PS3 and TV to play nice anymore. It was all hooked up and working fine (in 1080p) for months before this.

I went out of town for a week on a business trip, and I brought my PS3 with me in case I wanted to use it in the hotel room. I never actually used it, it stayed packed away the entire time.

I got home last night and watched something with my laptop hooked up to the TV via HDMI. Other than no audio (I think it was the laptop’s fault), it worked fine. I didn’t have to change any settings or anything.

This morning, I hooked my PS3 back up to the TV, turned it on and…nothing. My TV kept saying “no signal” on the HDMI port. I tried another port, same thing. So I hooked the PS3 up with the composite video cable and long-pressed the power button to reset the video settings back to default.

It came up in glorious full-screen 480i, and so I hooked the HDMI back up and a message came up on the screen saying something like “Oh, I see you have an HDMI connection, want to use it?” and I hit “yes, you dumb-ass, of course I want to use it!”

Screen was blank for 30 seconds, then comes back up (on HDMI) but just 480p. I go into the Display Settings, and then the Video Output Settings, and try the automatic option for the PS3 to use 1080p…no dice. Thirty seconds of blank screen, then resetting to 480p. I tried the custom option and manually selected 1080p, same thing. I can’t get anything other than 480p on HDMI.

At firwst I thought it was more of a TV issue than a PS3 one, since it seems like the PS3 is trying to output 1080p and the TV is like “Aww, hells no” for some reason.

It’s a Westinghouse TX-42F450S.

I also hooked my laptop back up to the TV, and the TV displays that in 1080p just fine…so maybe it is the PS3.

I also did some googling and there appears to be a widespread issue with PS3’s and Westinghouses not undergoing the HDCP handshake properly, but this doesn’t seem to be that issue…people with that report a lot of flickering/blinking, not a blank screen like I’m getting.

Well, problem solved…after more google searches one other person had a similar problem, and just used a different HDMI cable, and it fixed the problem…I only own 1 HDMI cable, so I flipped it around…yes, I put the end plugged into the TV into the PS3 and vice versa…now, in theory, this shouldn’t matter one bit, but it worked.

If it happens again, you can also hold down the reset button until it beeps 3 times and that should get it to re-recognize the system.

You accidentally forced a resynch. Powering off equipment in certain orders and unplugging it forces it to resync when they come back on. I doubt the cable flipping did it.

When my power goes out, I sometimes have to unplug/replug, or some combo of full power off, unplug/replug… depending on actual device, etc.

.