Chrome doing weird shit again

Chrome keeps trying to download a file (Chrome (3).exe, for example). I always discard it, but I can’t figure out how to stop this from happening.

Any words of wisdom (other than “buy a Mac!”)?

One time bump. Does anybody have a clue as to what the hell is going on with this?

The (3) looks suspiciously like what Microsoft adds to files to prevent duplicates, but I don’t have any additional information on why Chrome would be trying to download the 3rd version of a file. I am having some Chrome problems myself, but related to printing (.pdf files).

Sorry I can’t be of more help.


My problem is assbackward.

Palemoon, ( Firefox lite for windows only ) keeps saying I need to install Adobie Flash and I have the latest, so I got try again & it says I got it already. Rinse, repeat several times over a few days.

I have the most updated version of Win-7 Ultimate, Palemoon, Adobie flash, etc.

Same url in Chrome works fine… I don’t want to use Chrome, I want Palemoon to work.

Any ideas or similar problems with Firefox vs Chrome??

Everything is all patched, up to date, scanned & checked.


With all the people on this board, I can’t believe that this is a unique problem to me, or has not been experienced by others. It only happens once per session, and seems to have started when I was having a different problem and tried to download an updated version (which didn’t work).

Turned out, Chrome didn’t like the fact that I had not turned off my computer (Windows 8) in quite some time, and was exhibiting odd symptoms. I rebooted and the problem went away, but then this bullshit started. At first I thought it was the update trying to download, and clicked on the .exe file. An error message popped up saying it wasn’t possible to do that. Tried again, same message. Now this thing tries to download nearly every time I open Chrome, giving me the option to open the file or dismiss it.

I would suggest backing up your Chrome settings. In fact, back up bookmarks and then back up all via synch separately (more in a minute). Make sure they are backed up to a place not within the Chrome folder structure.

Completely uninstall Chrome using Add/remove Programs. Run CCleaner’s registry cleaner to get it good and scrubbed.

Reinstall Chrome. Import your bookmarks. If everything is hunky-dory, then get your settings back via the synch. If bringing back your settings causes problems, then do it all again but this time don’t bring your settings back.

That should be easy to try, as I don’t keep anything really important on this computer, very few bookmarks, etc. I think I’ll just uninstall the damn thing and clear the register and start over. I don’t have this problem at all on my PC, only on the laptop. Despite all this, it still beats using IE.

Chefguy, go here and search: Search results - Google Chrome Help

I had this in Firefox for a few weeks. I would usually just hit the “use the old version anyway” prompt. After a few weeks I thought I’d give it another try. Downloaded Flash and then it worked. Sorry I can’t tell you why. Since Adobe wants to update its software every time the computer has any updates I just assumed it was Adobe’s hair trigger update process having the hiccups.

The answer to the question there is “run a malware program”. I have Malwarebytes and have already done so.

Did as you suggested, and the problem is gone (for now). It apparently automatically saved my bookmarks. Thanks.