Compu-graphics question: I can't delete .eps files?!

Please help me, o’ wise tech types! Every time I try to delete an .eps file from my system I get an error message, accompanied by that obnoxious Windows “BONNNNG!” sound, that the file is either “in use by another program” (it isn’t), or is protected (it isn’t). Huhhhh?

I’ve tried everything I can think of, and I still can’t get rid of the fuckers. Is it maybe some weird protection ‘thing’ based in Adobe Illustrator? Maybe the .eps files in question are being used in an archived Quark or InDesign document?

I’m at a loss.

.eps is usually Encapsulated PostScript. Often used for printing. Are they in your print queue?

A number of people have found that .eps files are “in use” by Windows Explorer, and can’t be deleted as long as the desktop is up. Various fixes that have worked:

  1. Reboot in “safe mode,” and delete from there;
  2. Go to the Task Manager (CTRL-ALT-DEL), exit explorer, delete the files, and restart explorer;
  3. Download and run unlocker.exe from

I can’t promise that any of these methods are safe, easy, or even possible on your computer, but it’s a start.

  1. Safe mode should be fine. That was my gut instinct when I read the OP as well.
  2. explorer.exe starts itself back up again when you end the process… but it might work, actually. It depends whether or not it reassumes control of the .eps files.