Computer loses internet access after being left on

OK, so I have a rather unique problem with my PC. If I leave it running for a while (I have not yet determined how long, but more than a few minutes) I lose my ability to connect to the internet from programs not already connected. That is to say, a new connection cannot be made, but existing ones are intact. Aim is running fine, but if I try to load Firefox, it can’t find any site. I was playing City of Heroes for a while, and I never got disconnected, but when I quit and tried to load Firefox…no connection. I log off and on, and that does not solve the problem. Only a restart solves it, and only for a short while. I think it’s my firewall (Zone Alarm.) If I turn it off, I can get a connection. (I only turned it off for a few seconds to verify this.)

I don’t understand. I’ve had this configuration for months, and up until this morning, everything worked fine. I have not made any changes to my system at all since last night.

I scanned for Spyware with both MS Spyware Blocker and Spybot, and had nothing. No viruses as reported by AVG. Currently, I have Zone Alarm firewall turned off, and have Microsoft Firewall turned on.

Any suggestions? I think I might just uninstall Zone Alarm and reinstall, but if there’s some kind of “reset” option for it, that would be easier. I couldn’t find one. I put it back to default settings, but I’m looking for an option that will reset what programs can and can’t use the internet.


Burry a sprouting potato under a red geranium at the next full moon, turn three times counterclockwise while saying “Internet gods, smile down on this offering!” four times. But only if you are a boy. If you’re a girl, bury the potato under a pink geranium.

This is the most helpful advice I have. Good luck.

I have this exact same problem and have been rebooting a lot. It sometimes goes away for a few weeks only to come back. Today I had to reboot 3 times. The only thing I have left to try is a complete reinstall, but I really, really don’t want to.

Update: I started up this morning, and AIM started just fine, but Firefox still wouldn’t connect. I turned off Zone Alarm (with windows firewall still on) and it worked fine. I’ll do an uninstall and reinstall of ZA and get back to you.

Sounds like Firfox got on your ‘blocked programs’ list somehow. Open ZoneAlarm, click on ‘Program control’, click on the ‘Programs’ tab, look for Firefox. Make sure it has a green check in both access columns (Trusted and Internet). If it has a red X, ZoneAlarm will block internet access by Firefox.

My advice is to not use ZoneAlarm at all… it’s the worst POS firewall. Besides, you shouldn’t be using dual firewalls, since you have MS firewall enabled.

What’s a better (free) firewall program? And I only have MS firewall enabled because Zone Alarm isn’t working right, and I need soem kind of firewall. I don’t like MS’s, as it’s very restrictive and doesn’t have as many options and settings.

Are you using wireless?

I loves me free Zone alarm … that said… I had a go round with Irefox acting that way and I just deleted Irefox and reinstalled the latest version.

I’m on an old 98se 600hz box.

What was said about checking your settings in ZoneAlarm. also if you have a Router/switch between you and a broadband connection, make sure nothing changed there.

I have AOHell, IE, Irefox and Ophra all as browsers since I use what ever works best on my favorite sites I go to. Do you have another browser you can check to see if it will get out as a way to try to isolate the problem?

Sygate Personal Firewall, available from, is great. I use it behind my router just as a “belt and suspenders” approach and it’s so much better than ZoneAlarm.

I liked ZA but started having odd problems not unlike what you’re having with my cable connection. On advice from my ISP, I had to not only turn off ZA but actually uninstall it - it was getting in the way even when supposedly “off”. Fixed the connection like magic.

I have been having the same sort of problem. I can usually clear it up for a while by flushing the dns, but it always comes back. And it affects IE, Firefox, and Eudora, along with everything else that tries to access the internet. At the same time, my laptop can connect with wireless. I have tried shutting off everything except my virus protection and Zonealarm, but it still occurs. I guess I will try losing ZA and see what happens.

OK< uninstalled adn reinstalled and it fixed the problem for all of last night. This morning, it was back again. Argh.

I look in the programs tab, and Firefox, IE, and AIM all have access, yet they cannot connect. I can’t even ping an address in command prompt, yet I an renew my ip address.

I have no router, just straight from cable modem to my box. I run XP…eh, it’s not that big of a deal, since this weekend I will be installing a new motherboard and harddrive, and putting a fresh install on windows on that hard drive.

One of the Windows Updates sets the NIC to be turned off to save power. That gave us problems on some machines. Check the properties tab on the NIC.

What have you come across that makes you think it’s a POS? (asking because I use it and it seems to run OK.)

I can only repeat: uninstall ZA and don’t reinstall it. Use something else.

Oh, and have you checked for worms, trojans, virii and spyware?

Sorry for the post and run… I had to go to the doctor. Personally, I use Kerio personal firewall… I’ve never had good luck with ZA, but your mileage may vary.

In fact, the built in firewall in XP is pretty good also… thank in conjunction with the anti-spyware program has kept me pretty safe.

My father’s desktop has the same problem. He has to reboot several times a day to access the internet. If he is using the internet it is fine, it is only when he steps away, and then only sometimes, does it not allow him to reconnect. However, I can always access wirelessly from my laptop. The experts told us it was a worm. I have to agree with that; its the best I got. Spybot, Adware, AVG, etc will not detect it. No help to offer you, but at least you know your not alone.