Mozilla Firefox question (annoying)

Sorry to clog up the boards with another computer question but my Googling turns up thousands of sites, most of which deal with Linux. The Dope Search turns up lots of answers, but none for my question.

Anyway, here’s the deal: I switched over to Mozilla Firefox as my web browser a few days ago. I’m using it on a Win XP system (SP 1) with a DSL connection. Things work great, tabbed browsing is awesome, etc.

The computer itself is a desktop that does not go into sleep mode; only the monitor does. However, when I leave the computer for a while (say more than five hours) and come back Firefox can’t seem to find my internet connection. This happens whether Firefox was left open or if I closed it. In both cases after a certain period of inactivity the connection becomes “invisible”, and I get the “Resolving host…” message for a while, until the “The site could not be found” message.

The weird thing is, this affects every program that I normally use for internet access. Once this happens Internet Explorer, Outlook, Outlook Express, etc…none of them can find the connection.

This started happening only after I installed Firefox, and the only solution I have found is to restart the computer.

Has anyone experienced this problem before? Is there a fix, or is it simply the “price” (heh) of using beta software?

If you don’t use FF in a given session, does it still happen? If so it’s nothing to do with FF, perhaps your lan card is going into hibernation mode. Check for this in teh bios.

Are you using ZoneAlarm by any chance? I have a similar problem with that, after a period of inactivity I can’t get an internet connection on Firefox. I have to shut down and restart ZA.

The DSL connection isn’t using PPPoE by any chance, is it?

Well, it just happened again.

And yes, I am using ZoneAlarm and PPPoE.
I haven’t tried avoiding Firefox yet…I’ve only noticed this problem since I installed it, so I’m assuming that it’s Firefox related.

Thanks for the replies so far…

It’s sounds very symptomatic of a Winsock problem. You can look through the four links here to find some possible fixes

Many network cards have a “sleep” feature, perhaps yours is turned on and causing problems?

Interestingly, we had this same problem on my wife’s brand new laptop last week, except it couldn’t find an internet connection from the very moment that it was started up. I couldn’t figure out what the hell to do. I checked all the network settings to make sure that they were the same as those on my desktop (we run both computers through a router), and everything seemed to be normal.

I shut the computer down and restarted it. Nothing doing; i still got the “Resolving host…” message. In frustration, i turned the computer off and left to do other things. I came back later, turned it on, and everything started working fine. I don’t know what the hell the problem was, or why it went away, but since then we’ve had no problem at all with the connection.

Sorry i can’t be of any help!

Hmm. “Resolving host” type messages often mean a DNS failure. The DNS (Domain Name Server) is what translates a name ( ) to an actual IP address ( ). This is necessary for any program that uses names instead of the actualy numbers.

Try a direct IP url. For example: is or is . If the IP url works and the name url does not, then you have a DNS problem.

How to fix that is another issue.

Pilot141, I had exact same problem except I am on Win-98se. Irefox was good if I used it quick and left it on the web. If I waited too long, it was way slow or would not go. Hat to reboot.

Did a adware and Spybot, scan and defrag, and it started working okay. I donno why.

Also did some of the speed it up tweaks and that helped.

When you first fire up, get it on line and running and then set a new ‘restore’ point. Shut down and reboot.

Working better for me now and does not have to be launched right away, can wait and it’ll still fly…

Good luck…

Well, don’t :slight_smile: You really need to diagnose it down, so just try it - reboot and do not use FF at all for a while. If, as I’m guessing, it still happens then it’s a coincidence and nothing to do with FF.

Check your lan card drivers settings and also in the bios for any sleep mode or hibernation mode, and turn that off.

Checked the BIOS and LAN settings…nothing that I could find.

I always leave the computer running…and until I started using Firefox I never had this problem. And since I’m using it to post here now, the non-usage test will have to wait a while.

Thanks again for the help so far…

I’ve been having the exact same problem: every morning, I can’t get to any sites until I either refresh my connection or restart the computer. According to this thread on the Firefox support forum, this is most likely a problem with ZoneAlarm, and sure enough, once I shut down ZA my connection magically came back.

I’ve been poking through the ZA support forums, but haven’t found a solution yet. The only suggestion I’ve found so far is to grant “Generic Host Process” access rights for trusted and internet zones, and server rights for the trusted (but not internet) zone, but mine was already set to grant those permissions, so that’s clearly not the problem, for me at least.

Have you upgraded to ZA 5.1? It looks from the number of threads on their forum about access problems, this version is buggy as hell. I’m going to try reverting to 4.5 and see if that fixes the problem.

Then again, I may just try a different firewall–can anyone recommend a good free one?


I use Sygate Personal Firewall, and it seems to work fine. Also, it gave me no problems at all with Firefox.

Geobabe, yeah I’m using ZoneAlarm 5.1. I should have suspected it earlier!

I’m in the process of switching to Sygate as I type this.

Woo-hoo! Problem solved!

ZoneAlarm was the problem…it just didn’t work well with Firefox.

Thanks for the help everyone!

Thanks for the recommendation, mhendo. I think I’ll give it a try as well. Another friend also recommended SPF and said there may be problems with ZA’s security.