Computer Won't Recognize iPod

I hooked up my iPod to my computer and it showed the do not disconnect screen on the iPod so what did I do? Disconnect the iPod :smack: Why? Becuase I am an idiot. All at once lets point and laugh at the idiot. Ha-Ha. Ok good now that is out of the way lets try and fix it. Now when I attach the iPod it doesn’t work and it gives me an error saying that it doesn’t recognize the device. So how do I fix it?

From Apple support:

Your Windows PC doesn’t recognize iPod.

iPod doesn’t appear in iTunes or on my Mac desktop.

[brag]whose brother was one of the two hardware engineers who invented the iPod[/brag]

Tried that but none of it deals with the problems I am having. I can’t see the iPod in explorer or anything.

Why would you expect to see your iPod in a Web browser?

Windows explorer :slight_smile:

Reset your iPod and restart your computer.

<worships in your general direction>

That’s the greatest claim to fame I’ve ever seen on these boards! If he was my brother, it would be in my sig and I’d use it on every post! Them’s OBNOXIOUS bragging rights.

I had a similar problem the other day with my iPod. I was trying to transfer my music library from one of my computers to another. The iPod was recognized on the computer that held my library, but for whatever reason the other computer would not recognize it (not in iTunes nor Windows Explorer). After much stressing and failed trouble shooting (including a reset and multiple restarts), I simply plugged the USB cable into another port. For some strange reason this worked and both iTunes and Windows Explorer recognized it immediately.

I’ll be damned if I know why this worked. :smack:

Just to cover the basic answers:

Do you have a USB2 or Firewire port? It won’t work (I tried it out of curiousity) with a USB port.

Ah-ha! This must be why my iPod works fine in the FW port that’s built into the motherboard, but not on the add-on FW card. Strangely, my FW external hard drives don’t care which port they’re plugged into.

Hm this might be part of the problem. I plugged my ipod into my usb splitter which is only 1.1. I plugged it directly into the usb port which is 2.0 but it still doesn’t work.

O.K. so if I plug my iPod into my usb splitter it works but if I plug it directly into the computer it doesn’t. Any ideas?

Gonna bump this back up to the top:

When I plug the iPod into my usb splitter I get a message saying ‘High speed device connected to a non-high speed port’ but when I plug it directly into the the USB port my computer doesn’t recognize what the device is and it says it has no drivers for it. Any ideas?