Computers and Movies

Do any of you watch DVD’s on your computers? Does it bug the hell out of you when the video and audio aren’t synchronized?

It takes some time for the onboard video processor to do its job. This is, comparatively, a very data- and throughput- intensive task, so it takes much longer to do than audio processing.

I suppose that usually, the audio is delayed automatically by some piece of software so it synchronizes with the video.

But I have separate video and audio cards, and my video always lags about .25s behind the audio. There’s no skipping, it’s just that the audio comes before the video. This is *extremely *annoying. I have a fabulous and well-maintained computer - viruses and spyware are not a possible cause, as it’s not even connected to the internet (a separate computer from this one, obviously).

How do we fix it?

I don’t think the following information is relevant, but I’ll include it anyway incase you are curious: Asus motherboard, 2.8GHz Intel P4, 1GB RAM, Windows XP, a Radeon 128MB AGP graphics card, and Digidesign external sound processing (this is professional audio recording equipment).

And unless you come up with some Windows and driver “settings” that are completely off the wall, I’ve probably already tried it!

I thought this was going to be a complaint about utterly ridiculous computer use in the movies. I mean, what’s the deal with keyboards making “beep” sounds?

Anyway, inside your computer there may be a place to attach an internal audio cable (typically consisting of three wires - red, white and black) directly from the DVD drive to one of the audio card’s inputs. Try that. Or plug the speaker miniplug input into the jack on the front of the drive, if it has one. This may help you bypass whatever delay your computer is injecting.

Before you open up your case and start soldering things together check your software. Most if not all DVD playback software have a way for you to sync the video/audio

This simply should not be happening on a computer like that. I have two theories, a) Lag b) Anti-lag (bear with me).

For a) I’d suggest making sure UDMA is enabled on your DVD drive, and if it is, try different DVD software. VLC Media player (free) plays DVDs and almost always works well for me, try that.

By b) I mean that your DVD software might be trying to compensate for normal audio processing delays but is somehow unwittingly using ASIO drivers for your sound processor and is getting instant response instead. In fact, it might be using a synchronization method that is not compatible with your sound driver (I’m not too familiar with the ASIO/WDM architecture to come up with a more specific theory). If your DVD software has audio device selection try selecting the WDM device, if available. Try different DVD software (VLC or Mplayer)

I appreciate everyone’s input, really. The manufacturer of the computer could not help me out, and Geek Squad could not help me out either. I would try a forum dedicated specifically to computers, but all the ones I’ve seen are very poorly organized and their users apparently don’t know how to write one coherent sentence. I can’t take advice from people who write like that!

I’ve tried all the player settings I could find - I wish there was a way to manually indicate the desired delay in order for the two signals to sync, but there isn’t! I also tried different players (Quicktime, Windows Media, Actual Player and Power DVD).

I enabled UDMA. It didn’t help with this particular problem, but I’m sure it will help with other applications, so thanks for the tip.

My sound card *DOES *use an ASIO driver, I bet you’re exactly right that is what is fucking it up.

If anyone knows how to sync an ASIO audio driver with the video from a DVD, please let me know! I’m offering a reward of one year subscription to the Dope.

I should add, there are some practical limitations to the desired solution.

  1. I am not looking to spend money on more hardware.
  2. The reason I’m using these video and audio cards is because of the vast improvement in signal quality, so I don’t want to bypass them.
  3. I’ll be the only judge of whether your submitted solution works or not. But rest assured, if it works I will be more than happy to pay your SDMB subscription fee next year.

I’d kinda like to know if there is an internal audio cable connecting your DVD drive to… well, anything.

There isn’t. DVD drive connects to the motherboard as usual (just like a hard drive) and the audio goes out through an IEEE 1394 (FireWire) connection to the external sound processor by Digidesign, the 002R.

I’m pretty sure that there are a few DVD players that allow you to offset the timing of the audio. You should check that first. I’m pretty sure VLC would do it as it does, well… everything.

If you don’t get a solution here, can I recommend the Audio/Visual forum over at Arstechnica ? The users are, by and large, literate.

Thanks groman and Merkwurdigliebe.
I tried VLC. Breakthrough! It does have an option to delay the audio!
But I’m not getting any audio out of this player at all. Pity. I’ll keep messing with the settings, and I’ll let you know if I succeed.

As others have mentioned, some players do indeed allow you to specify the audio delay manually. One such player is MPlayer, which is Free Software and available for many computer systems. I use it myself; I occasionally come across the same problem you do with certain video files and can easily fix this by pressing + or - while the movie is playing to adjust the audio sync.

Media Player Classic lets you offset audio (options -> Audio Switcher)

(with QuickTime Alternative and Real Alternative it will handle QuickTime and Real stuff as well as DVDs)

Just for the record, my old 300 MHz PPC-based laptop computer never had problems with DVD’s.

Back then it was still a novelty, and stewardesses would always be curious about it.

IIRC, newer versions of VLC do not support AC3, the predominant audio codec used on DVDs. I forget exactly when they stopped supporting it, but I know for sure that 0.8.1 works with AC3. Here is their archive of previous versions.

**Big winner here. **Thanks a lot Capt’n Phart! The Media Player Classic works like a charm. I will contact the administrator about your subscription for next year. Your help is much appreciated. Even though it seems like a simple fix, I could have never thought of it myself because I hadn’t used that player before.