Copying and pasting images into emails

Time was, I could right-click an image, copy, and then past the actual image into the body of an email.

Now, though, I am noticing that this often does not work. When I paste, I will get either a lengthy url pasted in the email or an attached file (that you must click on to see the image).

Is there something I can change to allow the actual image to appear in the email? Or is this just how it’s gonna be.


Pasting an image into an e-mail has always resulted in either a URL or an attachment. There is no other way it could be done. If anything’s changed, it’s just that your e-mail client, for whatever reason, is now making it less transparent for you.

What software, or website are you using to send the email?

I think that what you’re trying to do is “embed” the image. This is a kind of attachment, but it also includes codes in the body of the email that link to the attachment, so that most email clients will just view it seamlessly.

Make sure that you’re sending the email in HTML mode, is one tip I can thing of.

Here is how to do it!

  1. Have the image you want to show in the body of the email saved somewhere (like on your desktop).

  2. Open MS paint. Under the ‘File’ tab at the top select ‘Open’ and open the image from wherever you saved it.

  3. Click on the hatched square above the ‘Select’ button near the top, which then allows you to create a hatched square around the image. Right click on the hatched square and select cut. This will remove the portion of the image you selected.

  4. In the body of your email right click and paste.

And there you go!

Mr. Doremro, I suspect that that, or something like it, is what the OP is already doing, and it’s now no longer working (at least, so far as he can see) in the same way that it used to.


Images are not natively supported in email. That doesn’t mean many email clients don’t render them anyway, but as Chronos said, it’s always either a fancy way of referencing a graphic file attachment or it’s an external reference to an image stored elsewhere.

And there’s zero guarantee that the recipient is going to see it the way you intended. It may land as plain text with an obvious file attachment, it may show up as an array of hideous-looking raw HTML markup code referring to an image that isn’t being fetched on that person’s screen at all, it may show up inline but not where you stuck it or not proportionally rendered or any of a dozen other things.

Maybe I misunderstood, but in Outlook 2013 when I try to cut/copy + paste an image into an email it shows up as an attachment (or as a URL if copied directly online?). Same as the OP describes.

The only way I can get an image to show up in the body of an email is through MS Paint…

For the record, it is Outlook that I am working with.

What is odd is that it works on some images, not on others.

For example, say I want to sent someone an image of a tufted titmouse. I Google ‘tufted titmouse’, select images, and thousands of titmouse images are displayed.
Now, if I select one, right-click COPY, right-click PASTE into the body of an Outlook email, it may or may not display the actual image.

I may work my way through 5 or 6 titmice before finding one that will properly paste in the body of the email, but I will eventually find one.

I am trying to figure out what the difference is between ‘pastable’ and ‘non-pastabe’ images, and if there is any way I can work around it.


WAG: Pay attention to the file types of the images (jpg, gif, png, etc.) and see if that makes a difference?

It can also be a HTML <img> tag to an external resource. (As in tracking pixels)

Which browser are you copying from? Most browsers have multiple options for copy, e.g. Chrome offers “copy image” and “copy image address” options when you right-click on an image.

Also, it matters what the e-mail format is. In Outlook, click on “Format Text” on the menu ribbon and there should be a “Format” group that lets you choose between plain text, rich text and HTML. Plain text messages cannot contain images. Rich Text and HTML should both allow it, but there may be different limitations on what you can do with imates.

I’m using Windows 10 and the snip tool is great for copying images and pasting directly into an email. Saves time hunting and pecking around with files to see what works, I’ve never had a snipped image not work. Of course everyone I deal with has the latest Outlook so YMMV.

Just because Google image search brings up an image doesn’t mean that image is actually available in a normal way. Before you try to “copy” the image, hit the “View Image” button which should show you the image at its native location. If you copy that image, it should work.

Have you seen the differences in the e-mail as seen by the recipient, or just in what you’re sending? What about e-mails with images that you receive from other senders?

I’ve never copied images directly from a browser and had it work right. I click “view image” then “save image” then I open it in Windows’s native photo viewer and copy/paste from there. Works every time in Outlook for me.

I use Outlook 2010. Copy/paste does what is described in the OP.

The fix is to start a new e-mail; click into the body of the mail; click the Insert tab; click “Picture” on the Illustrations group; browse to where you saved the image.

This puts the image in the message, the actual picture with no link or whatever.

Again, does doing that make it look right to you, or to the person you’re sending it to? Does it look right only in Outlook, or does it also work the way you want for recipients using other programs?

I am using Outlook 2003.

I am also not copying from what the image search displays - I do click on ‘View Image’ before copying.

I don’t know what the recipient sees, because I never send them that way.

To clarify:

[li]I do a Google search for ‘kittens’.[/li][li]I find a kitty I like.[/li][li]I click on ‘view image’ for that kitty.[/li][li]The image opens up. I right-click and ‘copy image’.[/li][li]In Outlook, I begin an email and right-click and ‘paste’.[/li][/ul]

Now, one of 3 things happens…

[li]I get a nice kitty pasted directly in the body of the email[/li][li]I get a very long, garbled alpha-numeric string of characters, or[/li][li]I get a link pasted into the attachment bar of Outlook[/li][/ol]

It seems I am getting #2 or #3 much more often than I used to.

Thanks for all the help.