Database error when attempting to subscribe.

When I try to purchase a member subscription, I click on User CP, Paid Subscriptions, select the subscription I want, then I get a database error. Is there something I’m not doing?

I’m not in any way competent to answer your questions, but we HAVE had a disturbing number of dreaded “database errors” the last week or more.

Question: did you try to subscribe more than once? IOW, did you repeat it, and still got another database error? This might help xash or Jerry.

Jerry has asked our hosting company if they did anything to squeeze the resources we share with the rest of the CL servers. They did something to the Chicago Reader server last week and we’ve been getting database errors since then.

If it failed once, just try again. If it fails repeatedly, let me know.


I’ve tried three or four times since the user titles were announced. I’ll keep trying.

I’ve just had another go, still no joy. I don’t get database errors at any other times while browsing the SDMB.

What browser are you using? Could you try another browser?

Make sure your username is in the box above the subscription menu, and the subscription you are choosing is “Straight Dope Board Membership” for $14.95

I’ve tried IE and Chrome, I’ll try some others. My username seems to be correctly entered and I’m choosing the only option which is membership for $14.95 US.

I just wanted to chime in . I to have been getting the data base errors and also some weird : Missing Security Token messages. This has been mainly happening in my user CP and when responding to polls. This has been happening using Firefox, I haven’t tried any other browsers yet.

Here’s the answer to the security tokens issue. It’s the version of Firefox you are using.

Thanks Shadez.

Update. I’ve tried Firefox, Chrome, and IE multiple times, every time I click on “Order” I get the database error. I would like to give you guys some money, but I guess not much will happen until after the weekend?

I’m going to temporarily change your username to 1920. See if that helps anything. My hunch is that maybe the quotes in the username are causing some sort of exception. Other users have successfully subscribed, so it looks like something specific with your account.

Can you check now?


Yep, stand by.

It’s worked, I’m a member. Good hunch.

Hey, if you’re in the process of changing my username anyway, and it would best to have something with out quotes, can you change it to Richard Pearse?

It’s strange that that hunch should be right, considering vBulletin should have tested this scenario. But I’m glad it worked :slight_smile: Otherwise we might have spent a lot of time trying all sorts of database and server side stuff, and still wouldn’t have been able to figure out your issue.

Done. Although if you would prefer the old name, let me know and we can just do this workaround anytime you need to purchase a subscription.


Thanks for that. I was due for a face lift.