Disabling Firefox 21 Plugin Warnings

I noticed in Firefox 20 a warning, when supposedly Flash was having problems, asking me if I wanted to continue or disable it. It was a minor annoyance. In FF21, it gotten REALLY ANNOYING. :mad: Videos and games are slow, if my internet speed (due to my updating my AV) or the site’s server is slow, I get the warning. The slowness of the videos and games seem to beis due to the monitoring by this feature, as in it creates the very problem it’s reporting. Correct me if I’m wrong.

Now, there’s an option for “Don’t Show This Again,” but since I use CCleaner, I have to do it every time I open FF. Anyone know a way to disable this annoying feature permanently?

Type about:config (one word, nothing else) in the URL strip, hit return and promise to be careful.

Type or paste:
into the Search space to isolate that configuration setting from the zillions of others.

When plugins.update.notifyUser appears under Preference Name, double click it, which will turn its Value (the Value heading will be in the middle to far right on that page) to false from true.

That should take care of it. But if for some reason it doesn’t, you can change it back just as easily.

I don’t think that’s the problem the OP is talking about. And, no, the check is not causing the slowdown. The slowdown is causing the check. The check has been there since Firefox 4 or so. As the problem shows up with Chrome users, too, the problem is almost certainly with Flash.

Unfortunately, I am not finding much on how to fix the problem. Some users say a Windows Update fixed it. Others say a new graphics driver fixed it (Nvidia only). Others have resorted to downloading an older version of Flash. And one person just went back to IE, which uses their own Flash plugin.

The most promising one I’ve seen is about disabling Flash’s protected mode. This Adobe article will tell you how to disable it. You can try the other options it mentions, but the main one is under the “Last Resort” heading near the bottom of the page.

I have had protected mode disabled for a while for a different reason, and I have not had any problems with Flash running slow. I have had that warning pop up, but only when I’m using Remote Desktop from another computer. If I see the warning stop happening with the next Flash update, I’ll bump this thread to let you know to try turning protected mode back on. That is, if turning it off fixes your problem. It is the single slowest part of Flash, so I think it will.

I was totally unaware that the warning has been there since Firefox 4. I thought it was a new feature in Firefox 20 as that’s when I first encountered it. Something change with either Firefox or Flash or both to make it appear more frequent in Firefox 21. Firefox 22 was just released today, with a Flash update likely to follow, so I’ll see how it goes.

If CCleaner is causing Firefox not to save your “Don’t show this again” setting, then it seems like you could disable CCleaner before running Firefox so it can save the setting.

Ccleaner is a tool that deletes unneeded files and registry entries. Ccleaner isn’t preventing it from saving. It’s erasing the setting. I’m not sure why, since something like that should be saved in prefs.js, but that’s apparently what it’s doing.

If it’s changing the setting I mentioned earlier, it might be stopped with a user.js file that does the same as changing settings in about:config.

Settings in the prefs.js file are changed by the user.js file settings. If CCleaner changes the warning to on, the user.js setting will turn it off again each time Firefox starts.

Create a plain-text document (must be plain text), save it as user.js in the alpha-numeric folder inside Firefox’s Profiles folder (where the prefs.js file is), paste this into it

user_pref(“plugins.update.notifyUser”, false);

save the user.js document and restart Firefox (the semi-colon is required).

My user.js file has 52 changes in it, but because they’re all in one document, keeping track of them is easy and using about:config is passé.

It’s not CCleaner, don’t have it on this 'puter. Don’t think it’s Firefox 21 either, same flash game on the same site using Chrome and the “Don’t Show This Again” does nothing.

CMC fnord!