Failed Yahoo searches

Yahoo is my home page and when I go there to conduct a search, it does what it’s supposed to do. But when I’m on a different site and want to do a quick search from the little toolbar line top right of my browser, it almost always says “We did not find results for______________.” It will offer me some alternate search terms, but will give the same “We did not find results for” result for them. (I can do a Google search from there as well, but Yahoo has been my default for almost 20 years and I resist change.)

Is something going on with Yahoo? I’m using a 2-year-old MacBook and the latest iteration of Firefox. It’s been doing this for about a week now.

back in the 90’s i used alta-vista … since that time, google has remained my portal of choice. ffx replaced my mie at around the same time. currently running win-10 and firefox-48 … the browser seems bit sluggish from their previous iteration … also mouse-cursor has started acting erratic with my laptop. yes, i digressed.

it may be the latest iteration of your firefox … [ul]
[li]have you tried safari or chrome?[/li][li]have you tried clearing cache or all of yahoo’s cookies?[/li][li]have you tried ‘defaulting’ to another search-engine for a week … and then going back to yahoo?[/li][/ul]
you may get more pertinent results/discussions from mozilla’s forums at

It can’t possibly be anything wrong with your system, Horatio Hellpop; it has to be a limitation of whatever databases the Yahoo search engines pull from.

Why Yahoo would be having those problems now, I don’t know. The point is, it isn’t anything you or anyone here could fix.