Mozilla Firefox weirdness

Been using it for years. Currently running Ver. 37.0

My chosen Home Page is Google. Not Yahoo, or anything else.

A few months ago, I would be denied the ability to load a page. Could be any page. Instead, I get a Yahoo page that loads rapidly in its place. The tab reads, " DNS Solution Yahoo Error ".

The words in the search window vary. This time it reads, " temp delroy coms 164462 grid server upload ".

I was attempting to load the page from the National Academy of Television Arts and Sciences site that deals with Daytime Emmy Awards. ( I just got nominated :smiley: ).

Instead of loading that page, I get this page.

This happens incessantly.

So, what have I done?

  1. Remove Firefox and re-download and install.
  2. Made sure I clicked the little gray magnifying glass icon in the right-hand oval “Search” toolbar at the top, which takes me to a page that allows me to pick from one of many Search Engines as my default. When this first happened, Yahoo was chosen even though I’ve never done that procedure before, and don’t use Yahoo. I deleted all other options but Google, and re-set it, and re-started the machine.

No luck.

What. The. Hell ?

ETA: Macbook Pro OS: 10.6.8

What is your DNS?
Check in System Preferences-> Internet->current network connection->advanced.

While it doesn’t explain all of the weirdness you’re experiencing, Mozilla severed all ties with Google not too long ago and partnered up with Yahoo. One of the results of this is that Google is no longer the default browser in Firefox.

That DOES explain it.


I love Mozilla, but despite my repeated attempts to tell it to use Google as the Home Page and Browser, Yahoo is aggressively running in the background.

I call bullshit on that.

You could try rolling FF back to an earlier version? I’ve been running 31.0 with no problems like what you’ve mentioned…

That does not explain it. I’m running the latest Firefox without seeing a hint of Yahoo anywhere, or any other problems.

No idea what is causing your issues, though.


Are you running any extensions or add-ons at all? If so, kill them all and see what happens.

Alternatively, you can go menu button -> question mark button at the lower right- > restart with add-ons disabled.

Just to cover all possibilities since I don’t know what your repeated attempts involved - I assume that means you have changed your “Default search engine” to Google in your Search settings? I also removed all the other “One click search engines” besides Google, since I have never used them in any Firefox version. I’ve never tried making Google (or Yahoo) my home page so I don’t know if my suggestion is relevant; just pointing it out just in case.

I feel like a Newbie. Menu button ??

Canadjun, yes I did go to Search, clicked the magnifying glass and chose Google as my Search Engine- and deleted all other options. The only one shown-for the last few weeks- is Google.

No change.

Hamburger icon in the upper right corner. Unless it’s different on a Mac, I’ve never used Firefox on one.

Can you take a screenshot of what it looks like?

Maybe it’s malware or your ISP redirecting error pages to their own service, somehow partnered with Yahoo.

Mozilla says it’s probably a search extension malware:

Thank you so much, Reply. That resolved it. I went back to the NATAS web page I’d attempted to load and it loaded fine.

There were three add-ons. I removed all of them.

Solved !


Nah, 'twas Martian’s idea :slight_smile:

Same here.
Yahoo did invade Firefox a while back but I presumed that that was my ISP interfering (BT, as in BT-Yahoo)


What bothers the hell out of me, after the last couple of firefox updates, I keep getting that untrusted connection popup for google, and it will not take an exception and I can’t use google. I whip over to yahoo and do whatever i am searching for and the next thing I know, I try google and it works. Damned problem is intermittent and I don’t seem to be able to trigger it deliberately. Downgrading is not an option, I just want Firefox to play nice with Google all the damned time. None of the mozilla help info worked, and all they seem to suggest is downgrading back to 35.

^^^ Now that is weird! The update itself wasn’t consistent for me; when I finally caved and installed the update that eliminated Google as the default search engine, Firefox on my MacBook didn’t act any different, but Firefox on my PC switched to Yahoo. I was able to change it back, and so far it hasn’t reverted. I also made sure to remove Yahoo from the search provider list.

I sorta fix this stuff for a living. It’s possible you have some software on your system that will put those add-ons back. At the very least, restart your Mac and make sure they don’t come back.

I’d also check to make sure Firefox hasn’t got any proxy settings set. (It’s in the Advanced Tab in the options, under Network). And check your Apps folder for any Apps you don’t recognize, as well as any sort of “optimizers.” If you have any malware protection, Google it and make sure it’s legit.

Sure, you may have solved the entire problem, but it won’t hurt to be sure.