Firefox is showing things all wonky - why?

I have a fairly new (I got it at Christmas, it was refurbished) computer running Vista. Whenever I reboot the computer (or it restarts itself for some reason), Firefox goes all screwed up (and IE isn’t any better). For instance, when I try to view the board, the formatting is all screwed up and I get pages of what looks like source code, with strikethroughs and assorted gibberish. Hitting refresh multiple times nets varying degrees of wonkiness - full pages, half pages, half a page of normal before it goes to hell, sometimes just the banner. It does it on other sites too. I have tried clearing the cache. It seems to improve after a while but it’s bloody annoying to not be able to view anything clearing until then without hitting refresh 15 bloody times.

And save the Vista jokes - my old computer was 9 years old and this one was a gift.


Do you have any addons for Firefox installed? If so, try disabling them all and see if the problem resolves itself. If it does, re-enable them one by one until you get to the one that does the trick.

Also, the comment about your computer restarting itself for an unknown reason is a little disconcerting. I don’t have much Vista experience at all so I’m not sure if this would be an issue in the slightest (for all I know random restarts are a Vista feature), but it sounds like an anti-virus/spyware/adware/malware/rootkit scan wouldn’t hurt.

Hmmm…I know that I haven’t installed any addons for Firefox. I run anti-virus but I’m not sure if it does spyware. I think the computer is set up to reboot automatically when Firefox updates itself; it doesn’t do it on a regular basis or anything.

I will look into those, definitely, but welcome others.

I don’t think I could make my computer reboot when Firefox updates, even if I wanted to. When you say “reboot”, do you mean gracefully or not? Does it give you a countdown and/or warning, or does it go black screen, <click>, “Welcome to Vista!”?

Does the wonky text have anything to do with the affected web site, or is it truly random? Does it still follow the Windows behavior rules (i.e. does it highlight, scroll, resize correctly)? Or does get stuck in place and smear if you move the window? If you can still use the Firefox menu, go to View | Page Style > No Style. Does it look like that? Does switching it back and forth help?

Could you upload a picture of your screen? Press “Print Screen” on your keyboard to copy your screen to the clipboard, open Paint or some other graphics editing software and paste it by pressing CTRL+V. Upload it to or some other similar website and give us the link.

And you’re not getting any kind of error messages at all?

Ok, things seem to be improving a bit but I did try to take a screen shot. Unfortunately, it took a picture of my take-home final (which I’m supposed to be working on) rather than the Dope screen I was looking at. When I hit the “Print Screen” button, the monitor went black for a second and then I got an error message saying the display driver had stopped responding but had been restored (sorry, can’t remember the actual wording!).

I will try for another screen shot tomorrow after my English final.

An error message? Who was your manufacturer? I’m wondering if they checked to make sure they were using all components that are Vista capable.

Another thing is that the appearance changes every time. It’s not doing one thing consistently.

Video card, maybe?

Update the drivers, or get a new one.

It isn’t often that a Firefox update requires a restart but when it does a dialogue box pops up with a countdown timer on it and the option to reboot straight away or defer the reboot.
Vista does install stealth downloads and reboots spontaneously with no warning whatsoever.
Not very often though. Twice this year.

The persistent reboots sound like an overheating problem. Check for dust in the processor heat sink.

Sorry, I should be clear - it doesn’t reboot consistently. Occasionally it reboots when Firefox or Vista downloads an update (I’m usually asleep or otherwise not paying attention when they happen) but it doesn’t just do it randomly with no warning.

I had to reboot myself the night before last because the cable wasn’t working (all seems ok now) and it still hasn’t gotten better (it’s improved somewhat, but it’s taking longer, it seems).

It does sound like the video driver or hardware might be partly at fault (the bit where Print Screen doesn’t work), but if you’re seeing partial and corrupted pages, something else is also wrong - I’m not sure what though, as I’ve never seen anything like that before. Network card maybe?

At least yours was actually booting up. For about 2 months I couldn’t use my FF. I would click the exe and it just… did nothing. Upon looking at the problem from a different view I found the issue. I had to go in the “run” box and type “firefox- p” and use a new or alternate profile. Now, as for my iTunes and Quicktime, I’ve said to hell with them! No one has the answers…

Run DXDIAG, Save All Info, and post the resulting file here - just as much as fits here in one post will do.

Ok, now it’s completely stopped working, so I’m posting this from another computer. My box will not download and install an uncorrupted version of Adaware; I tried installing Spybot from an old .exe file I had, but it won’t download the updates (they all said, I think, “bad checksum!”) so therefore it won’t run. I’m going to try to do some kind of anti-spyware deal and see if that fixes it; seems like it’s the most obvious answer an I should have thought of it sooner. (Going to try to download a copy from this computer at school and take it home.)

That’s a known bug in Spybot when the source of the downloads decides to fail. Just choose an alternate download location for the updates.

Ok, I feel silly now. I managed to get an uncorrupted version of Adaware and I just ran it - 322 non-critical objects. That’s a lot. And now everything seems to be working ok.

I deserve this: :smack:

I’ll come back to this thread if it starts acting up again, but I think cross fingers that I’ve fixed it.