Have you seen this virus?

My mouse pointer has suddenly gotten all goofy. It looks like a tube of lipstick most of the time, and whenever I get it near something clickable (program or button, whatever) it disappears and reappears anywhere from a little bit to a couple inches away. Needless to say, this is making getting anything done very difficult. I can sometimes click on things if I move the mouse very slowly. Is this any virus you have heard of? And do you have any ideas for a cure? I ran McAfee with no luck. It just seems too whimsical to be a simple malfunction.

“Eppur, si muove!” - Galileo Galilei

Gaudere: Could be simply that the rollers (I’m sure there’s a more technical term) inside your mouse are dirty. Have you tried unscrewing the bottom, taking out the ball and looking at them? If you notice dirt, you could use a Q-Tip or even your fingernail to remove. Then again, it could have strictly nothing to do with this.

I cleaned the mouse; I didn’t think of that before (duh), thanks. However, I still can’t click on anything. It’s getting really tiring "tab"ing everywhere. Sometimes if I open a ton of apps it seems to distract it, and the mouse works Ok for a while.

I assume you’re running Win95 or 98.

It sounds like a strange mouse driver is loading as Windows starts. This probably isn’t a virus, but a Trojan you got from some downloaded program.

First check the date on your McAfee data files (Help/About) and update them when you find out that they’re old. Yes, they will be old. :frowning: That’s not the problem, most likely, but do it anyway.

Then go to http://hotfiles.zdnet.com/cgi-bin/texis/swlib/hotfiles/info.html?fcode=000YKL&b= and try the “Startup Cop” utility there. I haven’t used it, but the PCMag utilities are usually pretty good. The page says you can save a profile first (so you can get back if necessary), then disable any mouse drivers you find.

Good luck!

Bob the Random Expert
“If we don’t have the answer, we’ll make one up.”

Did you download a desktop theme from Microsoft? I saw a theme listed that displayed lipstick and other things of that nature. You could be running this theme and have a bad mouse, but no virus. You can pick up a cheap mouse, or borrow one to check this out.

Sounds a lot more like a mouse problem than a virus problem. The jumping mouse cursor is often caused by a hair caught in the mechanism. If you can’t click, it’s most likely the button has worn out. Buy a new mouse and you should be fine.


Thanks for your advice. It’s not that I can’t click, it’s that I can’t get near enough to a button to click. The mouse is less than a year old, but it’s conceivable that it’s worn out.

Have you ever tried to download a virus scanning progarm when you can’t click on anything? I could tab around for a bit, but there were radio buttons that needed to be selected and I could not do it. Fortunately I had a thought and switched from the mouse to my wacom art tablet–ah, I can click again!

I think the mouse driver problem sounds like the most likely explanation, since my mouse is new (and freshly cleaned) and I never download desktop themes. I can grab my mouse from work to check though.

Thanks a lot for your help, and if anyone else has any ideas, let me know.

“Eppur, si muove!” - Galileo Galilei

First, I would take the mouse of out of System. Disconnect it from the computer, restart, it then asks for you to connect a mouse, do so, & finish.

Also run the SFC.exe [system file checker] to make sure your system files are straight.


I’m assuming that you have rebooted your PC. Not just a soft boot, but actually shut down and then turned your PC off and back on to reset hardware.

I have seen something similar and it was actually a little exe that someone sent me that turned my mouse pointer into a little penis- but looked a lot like a lipstick. The only way I could get the program to stop was to reboot. Good luck!

One other thing to check. A mouse may work as you discribed, if it shares an interupt with another computer device. The most common conflict is with a modem. Check out your interupt asignments in the system properties programs in the desktop. Select “computer” and click “properties”. Your interupts are under the heading “setting”.

Well, I went for the shotgun approach and checked the drivers, properties, ran more virus scans, unhooked the mouse, rebooted, shut off the computer, rehooked the mouse…

…And it worked!!! I have control over my mouse again! I sure hope it stays that way, but it’s never gone this long without any problems since I got this bug, so it looks promising. I can’t thank the person whose advice actually fixed the problem, since I have no idea what specifically did it out of the things I threw at it. But all of you–omniscientnot, rjk, Phobia, RealityChuck, StStella and handy–have my boundless gratitude for your helpful advice. Thank you! Thank you! Thank you! :slight_smile:

“Eppur, si muove!” - Galileo Galilei