Help. Any linux (Mandriva One 2010) experts out there? Trying to get it onto my eeepc900


Here’s the scenario…

I have it on a CD, so I can boot both my PC and my Laptop into Mandriva fine.

I have a 1gb SD card. It’s not big enough to do the live install.

I also have an 8gb Lacie usb key. It is plenty big enough, but on both the PC and the laptop - if I plug it in and run ‘live install’ it exits prematurely. it ONLY does this when the lacie is plugged in. If I unplug the lacie it loads normally.

Similar things happen in the control panel areas related to disks.
I’m trying to get mandriva onto something so that I can transfer it to my eeepc. Ideally I want something like the CD (obviously smaller than 1gb). Something that runs in this ‘run from cd’ mode which I can then install onto the built-in hard disk of the eeepc.

But secondarily if I could install it onto the usb key that would do. I could then plug it into the eeepc and install it again on its internal drive.
Either way I want mandriva [or a similarly good and eeepc compatible distro of] linux on my eeepc.

At the moment it has an eval of w7 and no recovery partition (to enable me to restore it to xp) Prior to w7 it had linux (ubuntu I think but I’m not sure) but nothing worked, no touch pad, no sound, no wireless. I have heard that all that stuff will work with mandriva (it all works on the PC and the laptop)

I also want to avoid any complex fannying about with commands and downloading miniature tools to create boot disks.
eta: Would it work if I just did a straight copy of the contents of the cd onto the sd card?

I found a solution. I remembered that you can now shrink partitions in windows without losing the data, so I’ve shrunk a partition and made a new partition on a 300gb external hd I have. I’m now installing mandriva onto it.

It turns out that once you install it you lose the ‘live install’ option. So what I need is a bootable copy of the live cd on a usb key or external device.

If I understand your question correctly, you want to install Linux on the eee, but you don’t have a CDROM drive.

I installed Linux on my eee900 a while back. What I did was I downloaded the ISO file for the install. I then used the Linux utility “unetbootin”. It took the ISO file and created a bootable USB key. Don’t know if there’s a windows version, but if nothing else there are similar utilities to convert an ISO file to a bootable usb key.

I then booted off the USB key on the eee900 and installed from there.

BTW, which Ubuntu version did you try? I first tried the netbook edition, but had problems with wireless. I then switched to the regular ubuntu version for desktops and everything works great. Wireless, webcam, touchpad, all worked out of the box.

Edit: There is a unetbootin for windows:

To cut a long story short i’ve wasted hours on this and have just given up. one of the many things I tried was unetbootin as you mention. the computer would boot to the initial live splash screen then some loading, then I kept getting to a page of file copy and invalid argument errors and then ‘unable to open initial console’ and it would go no further. I would get the same error on a pc that The cd worked on (exactly the same distro)

I’ve seen this problem before and it turned out to be a defective USB key.

I was trying a key and an SD card.

Both seem to be fine when used as ordinary storage.


I tried two OSes, on two computers. About 3 or 4 different little programs (mandriva-seed, unetbootin, a hp thing,…) many websites, two different versions of mandriva (2010 and 2009).
IF [sub](and that’s a big ‘if’)[/sub] I decide to continue trying. I’ll try a completely other distro of linux. (mandrive was top of a list for eeepc)

But I hate conceding defeat like that. I might just not bother at all. I know I’ll end up hardly ever or never using it. I just wanted a full OS (i.e. not eval copy) that doesn’t take half an hour to show a keypress.