Horrible ancient software that never seems to evolve, but you are forced to use...

I couldn’t really think of a good title for this.
What horribly crappy stone-age software do you have to use in our day-to-day business?

I currently am thinking unpleasant thoughts about whoever is responsible for the ERWin data modeling tool.

It is a visual tool for designing databases. You drag little rectangles on the canvas and hook them up with lines, kind of like using MS Visio.

The problems:
o The app looks no different than it did in 1996.
o It is only in the past couple of years that they have even bothered with such new fangled Windows features as long file names.
o Today’s latest and greatest version is horribly buggy.
o Most of these bugs were present in 1996.

More concrete:
o When I select several objects and drag them, they sometimes retain their relative arrangements, but usually they are all jumbled. At least, the lines all get tangled.
o Cutting and pasting is equally buggy.
o Cursors change randomly to the wrong thing.
o Drawing specific settings such as “snap to grid” are immediately forgotten when you exit the app, even though you saved it.
o Pasting into MS Word works to a limited extent.

Maybe my biggest problem is that it’s an outrageously expensive application, but they haven’t really done anything to improve it or even fix major bugs since 1996!

But it’s all we have, and it does the job I need to do.

How about your apps? Anyone being forced to use a DOS app written in 1987?

I work in Healthcare and Insurance. We still use MUMPS for our basic claims software.

We’re being forced to upgade our early 80’s version to something slightly newer, because the developer will no longer support it, and we cannot find programmers anymore.

Why don’t you look at ERWin’s main competition.

See PowerDesigner vs. ERwin—A Technical Analysis.

You want old software; I can give you old software.

I do structural engineering in Texas. Three of the programs we use most are little DOS punch card interfaces. RDS (Roadway Design System) which lays out roadway geometry was last majorly tweaked in 1979. :eek: (to be honest, bridge designers are the only one’s still using it because it’s a lot more intuitive than Geopak) The manual is a hadgepodge of mimeographed typewritten pages and the first section has a little paragraph on what a computer is. The chapter on the information card explains how it gets the computer’s “attention” and has a little graphic of a mule being whapped with a 2x4. I think I’m gonna win for oldest software. :slight_smile:

And, actually, most of these programs will be phased out in 2007 when we go to the new design code. The engineers like these programs because they’re pretty transparent and the calculations they use are pretty simple.

How about mainframe-based apps? I got a desktop full of the buggers, all running through a 3270 emulator.

The mantra here seems to be “It’s working. Don’t touch it!”

In my radio job, I am the only person who uses Cool Edit 2000. I seem to be the only person ever to work here who understands how it works. The rest of the people, including the engineers, use this $800, 20-year-old software called FastEdit. It is the least intuitive audio software I’ve ever encountered. It’s deadly hard to edit sound files, it’s deadly hard to change the dynamics or do something as small as making a dip or a rise in the volume, or a fade out. It’s no wonder that none of the station’s work has been nominated for anything for the last two years - it all sounds like it was edited by a drunk, blind guy wielding pinking shears!

The program has absolutely no other bells or whistles. It gives you no indication of the overall level of your audio recording, except for a little number in the upper left corner, which shows the decibel level of the loudest sound. We are tied to this crap software at the moment, because it is used by the automation system. FastEdit is so old that it writes sound files without a data header on the front of the file. It also uses DOS filenames. The station’s automation system was designed by one of our engineers, who wrote his playback software to read files made in FastEdit. Every other known audio recording or playback program writes/reads data headers but does not play them back as sound! If that were not enough, we are required to convert all sound files that will be played on the automation system from standard wave files into another, obsolete format that nobody ever uses for anything. Every sound file must first be put on a Zip disk and loaded onto each of three computers from the Zip disk. No DOS network software must have existed at the time…

But that’s OK, because we are now forced to get a new, space-age automation system, because the hard drives on the current system are all dying from overuse. When the new program arrives, everyone will have no choice but to learn how to use Adobe Audition, the default audio software that comes as part of the package. I can already hear the grumbling. Who’d have thought that people who record sound for a living could be so technophobic?

We use a system designed by Bull years and years ago to keep information about prisoners.

It is very limited in the information it can hold, and they stopped training staff in how to operate the database some years ago.

This means that most of those who did know how to use it have now retired, I think there is one person in my jail that has a way of getting to various reports given certain criteria, but most of the time when certain information is required, such as ‘how many prisoners were released from my prison between two dates and were originally convicted of a violent offence’, it is such an pain waiting for that person to come in to work as he is now part time and on shift work, that these reports get quietly dropped.

…and yet it is essential to the running of the prison, of all the prisons in the UK and hardly anyone knows how to use it properly.

Tied into that same system is a stock control system called Stratege, apparently it was used by Boeing or some other giant corperation to ensure production kept running.
Its completely unfriendly, hardly anyone knows how to use it, the manual is just a many times photcopied smear but its not been shut down yet.

This stuff has to be 20 years or more old, its getting so that some parts cannot be sourced, and its not what you’d think, such as memory and processors, its things like case hinges, internal fans, mounting brackets.

Oh man.

I’m just trying to keep everything running.

We are moving all our data from a UNIX system to Windows SQL server.

I’m in GIS - Geographic Information Systems - Spatial Analysis. Most people would call it mapping.

AML code I wrote between 1995 and 2000. Very FORTRAN like. Thousands of lines of it. This runs a file based database system. UNIX base.

Avenue code. Almost Objects. Not really. Not COM.

VB6. Still not quite OO.

We are moving to a Intra-Internet based system. So I’ve been learning HTML, DHTML, XML, ASP, Jscript and Vbscript as I go.

I’m coding with Visual Inter-Dev right now. I have days of frustration, with the occasional break through.

I’m also learning about a product called SDE, Spatial Database Engine. And versioning an SQL database.

During this transisionary period, I’ve had to call on DOS commands for printing. I will be working on that some more tomorrow.

Oh god. I’m the lone sole (lonely!) librarian at an art museum, so not only am I in a forgotten department by myself, I work in the non-profit sector. To do the cards for the card catalog (yes you heard me right) I have to beg and tickle and feed grapes to this DOS program called “The Librarian’s Helper”. It dosen’t even work with even moderately recent cataloging standards, so to get correct modern cataloging you have to just wing it and print and see what happens. It’s green on black, of course, and prints to dot matrix, and it’s an adventure. It still keeps coming up with new surprises for me, every day. Of course, I have to use the thing all the time.

They took the computer out of my office because “Special Events’ computer died, and they bring money into the museum”. Now that computer was old, but it was workable. The workroom computer that we just keep around to print the catalog cards on is now my primary computer. It’s like turning a crank to make it work. Of course, I had to clean off all the watersports porn on it from our late unlamented volunteer before I could start trying to coax it into helping me catalog. :eek:

Excellent :slight_smile:

Now I can happily go back to work tomorrow and start using ERWin again with a proper attitude, having been told what ancient software really is. Some of the applications you folks describe sound painful indeed.

I also plan on peeking at the software linked to by astro. I’m sure it’s not perfect, but it really doesn’t have to be very good to improve on ERWin.

I use a barbaric program called EDS 3 (aka The Bane of my Existence, aka The Antichrist).

Even though it is supposedly written for Windows 95, it uses the 8.3 file naming convention.

When you go too deep in the directory structure, it adds three dots to the middle of the path, indicating it’s too long to display (c:\eds3\designs\…\whatever\file.ofm). When you try to open the file, it includes the three dots in the path name, returning the error “’…’ is an invalid directory”.

Even though you might have hundreds of objects on the screen, you can only copy and paste one at a time.

Edit-> cut, Edit->paste changes the object to a format that’s not modifiable, for no discernable reason.

When you change the colors of objects, you have to manually refresh the screen each time to see the new colors (and no keyboard shortcut).

On the various input windows, hitting “Cancel” is the same as hitting “OK”. So, if you made a mistake and don’t want to use the new values you typed in, too bad.

There is an “Undo” and a “Redo” in the edit menu, but they’re always grayed out. (and this is after installing the service pack)

Lots of “Divide by zero” errors, causing the program to crash.

It does not associate the files it creates with the actual program, so you always have to use its primitive file requester to open a file.

The list literally goes on and on.

The program “only” costed $20,000, so I guess you get what you pay for. :rolleyes:

Those of you who have posted before me already have me beat, but…

I did temp work circa 1998 at a printing company that still used an antediluvian software package for tracking jobs as having been paid.

It looked sort of like a DOS environment, but I’ve seen DOS on an XT Intel-8088 based system, and this was no 8088. Maybe, possibly, conceivably an entire single megahertz, but my best guess would be 500 KHz. Eight seconds between keystroke and response except for literal data entry which was much much faster (keystrokes would appear no more than 1.5 seconds after you typed them). Tabbing to a different field = the 8 second event.

The keyboard was something I’d never seen before. One key I used to exit and save the specific record I’d just modified was labeled “Clear Screen”.

The software was hideous — if you mistyped anything, you had to erase the entire entry and do the whole thing from scratch, no editing function. That made the cost of an insufficiently emphatically typed keystroke exorbitant, so I subjected that poor ancient keyboard to some serious whopping, the alternative being to muck along waiting for the UI (such as it was) to update before proceeding to the next keystroke.

The most ancient sw I still use now is something I have no complaints about: the vintage-1985 Desk Accessory “DeskZap” still works under MacOS 9 and even in Classic and is still, after all these years, the most elegant way of dealing with invisible files and obscure file parameters you’d like to be able to view or edit in one easy step.

As recently as '99 I worked on a company database that was the most second most astonishly crap system I ever had to use.

We used it through a telnet window. We had another telnet window for order entry, etc.

The most jawdroppingly :smack: thing that I remember out it was that whoever wrote the cussed thing never bothered to screen out break codes from user input – so if someone did something stupid like using a standard Windows keyboard shortcut (^C) (on their Windows PCs) to copy info from one window or field with the idea of pasting it to another, the application abruptly terminated – and was instantaneously inaccessable to all users until the sysadmin started it up again herself. We’re talking eight or nine people taking supply orders, half a dozen people dispatching techs, the four good women in the accounts department, and god knows how many others who relied on the same proggy for their routine stuff. The whole place regularly ground to a standstill – for want of one line of code. (Probably along the lines of IF x=ASC(3) THEN RETURN, if my dark suspicions were correct :D)

Ahh yes… Telnet.

I worked for a company in 97 that had their customers all across the country logging in to their Unix servers to run their huge monolithic database application.
Hundreds and hundreds of field offices.

The problem was not so much the old character-based forms; the problem was the telnet client. They were too cheap to actually pay for a proper telnet client, so they took some Visual Basic example code that implemented a very primitive telnet client, wrapped it up with a little bow on it, bugs and all, and sent it out to the field as part of their official production application.

The worst part about it was they expected developers to use the same awful tool for day-to-day Unix application development.

We have something at work called “Service Center”. It’s a ticketing system. If this isn’t the biggest piece of shit software, I don’t know what is. We’ve had it for like 9 years with only 2 version changes, and it still looks the same! Not to mention the millions of hangups. God forbid any one of the 20,000 users who decides to do a database search and causes everyone else to get hanged up on it for like 5 minutes!

Oh, and to add insult to injury my little nasty program promises to be (inappropriate quotes original to the disk - perhaps they represet irony?) “A Productivity Tool for Librarian’s”. [sic] I amuse myself by imagining what of mine this is a productivity tool for. Not to mention how not to end that sentance a preposition with.

Badly designed software makes me feel ill. Seriously. :frowning: This thread is upsetting.

I’m a software geek, but I’m paid to be. :slight_smile:

OK, 'cause I’m at work and have access to a scanner and am really, really bored. On this page, (the album called “rds”), I’ve scanned ina couple of pages from the user manual I was talking about above. See the com-pyuu-ter, machine of the future as visulized by the Texas Detp of Transportation…

Tremorviolet, that was hilarious. I wish I could find a system flowchart template that had a cool robot icon like yours. :slight_smile:

Human sends data to robot. Robot returns data to Hooo-man. Brilliant.


Thank God I’m not alone.

My boss made the decision to move backwards to get off of our UNIX box and load a local version of the software on the users boxes. Software that hasn’t been updated for 6 years or so.

The UNIX box is still available and not needed. The users boxes don’t do it. I need to be able to delete a file on a Win2000 server to make it run from the local box now. When I give the users permissions to do it, I get An error ‘ERROR OPENING HASH TABLE".


Take the permissions away and the base app can’t do it’s job because it needs to delete and recreate the file.

Open up permissions and the app won’t run.


Again, with FEELING… Open up permissions and the app won’t run. --‘ERROR OPENING HASH TABLE".

Weird, weird stuff. Works on my login, but only my box (15 miles away from the users box, trouble shooting is being a bitch). But I don’t have any special permissions. I even gave the user in question that it fails on admin permissions and it still fails. Our Sys admin guys don’t get it either.

Monday is gonna suck.