How can I free myself of Hotmail's chains?

I’m sure a good many of you are Hotmail users, and an even better many of you hate Hotmail with a passion of a thousand Vegas suns, and a reasonable many of those probably are still using it anyways since you are too lazy to make your friends learn a new address. Well, me too…

My biggest beef with Hotmail is their practice of opening any link within an email inside of that insidious and useless “You are visiting a site outside of Hotmail” frame header. The damn thing clogs up a good bit of prime screen real estate and is impossible to free yourself from. Each link you click is perpetually captured. Not to mention the occasional site that uses cookies or secure servers that get simply FUBARed. Fuckers…

Anyways, how do you cope with this? Short of always c&ping links or abandoning this POS service? Didn’t there used to be a nifty keyboard shortcut that let you escape frames into a new window or something?

I’ve been holding back a few weeks to see if Hotmail was going to join Google and Yahoo in offering a whole lot more free email space, but since they are sticking to a very measly amount, I’ll probably switch to one of the other free sitees that offer 50 times more storage capacity.

As soon as my GMail invites are working again, you can have one from me. They’re effing amazing.

Jay Dot Arr Dot Parsons At Gmail Dot Com.

As far as Hotmail storage, they announced an upgrade to 250Mb during the summer. So far, though, it hasn’t happened.

And, yes, I, too, have been frustrated by the “You are visiting…” frame for years now. I’ve become accustomed to copying and pasting the links I get…Not the greatest but not the end of the world, either.

jnglmassiv and Omniscient, your GMail invites are on their way.

You got a Gmail invite, if you don’t get it because hotmauil may be blocking them E-mail me at emanuel at levy dot net

Let me share a simple but useful trick. You can right click on a link and then select “open in another window.” This saves you the trouble of copying and pasting.

Shift-click does the same thing in IE.

Correction: “Open in New Window.”

My hotmail account was upgraded to 250MB a few weeks ago.

I got a few GMail invites to anyone who wants to flee from MSN. Email my username at with a first and last name (preferably your own, but I’m not picky), and the email address to which you want the invitation sent.


For Firefox users, I think there is a plugin designed specifically to get rid of the the hotmail chain. Look around their site. I’d link you, but I’m about to leave work.

If you’re using IE, you can right-click, then select ‘open in new window’.

For Firefox users you can ctrl+click to open in a new tab.

Maybe it’s just me, but when I try that, absolutely nothing happens. Of coures I’m testing this on my mom’s computer which blows, so it’s possible the problem is on my end. Help me XJETGIRLX :frowning:

This makes no difference. I still get the “you are visiting a site outside of Hotmail…” Copy link doesn’t work either.

Any way it doesn’t bother me enough to warrant changing. I was a paid subscriber ($20 a year for the extra storage) and because of that, when they started giving out the upgrades to compete with gmail, I got 2GB.

1¢ per 1MB is ok by me.

When using Firefox or Mozilla, once you’ve brought up the link, you can get rid of the frame by right clikcing and selecting ‘This Frame --> Show only this frame’.

If the site you’re looking at also has frames, you may be a bit screwed, but this will at least get rid of Hotmail’s frame.

<< I love deadlines. I enjoy the whooshing sound they make as they go by. >>

Try going to Tools > Options > Advanced, then under ‘browsing’ select ‘select new tabs open from links’

I don’t have hotmail so I can’t test to see if this works within their setup, but it should.

WTF!!..Mine has stayed at its lame 2Mb for years. What’s your secret?

Still no @#$%!ing capacity upgrade. And now something else…

EVERY link I open gives this in a new window:

Its getting horrible. I can’t highlight and copy every link (Buttons, embedded URLs, etc). I’m high and dry here. It never used to do this. I’m using Opera, btw. Please help me!

So was mine. . .

Anyone know a way to get around the ad that comes up on the right side of the screen? My computer freezes up for a good 20-30 secs waiting for it, but only when I use my account. When my wife accesses hers from the same comp, there is no problem.