How do I use an iPod nano, Esp. on Linux?

I won this iPod nano at a party this weekend. I’m used to other MP3 players, where I can just drag songs over. Using iTunes seems like a different experience, and I have no experience with it. Is there some “best” way to use it?

To make it more complicated, I use my laptop most of the time, where I have Windows XP, but I never boot it anymore. I use Linux now (Ubuntu 9.04). iTunes isn’t available for Linux, but reading online, it seems they’ve got Linux software that works with iPods. Anyone have any recommendations? I do have WINE installed.

I also have a desktop running Windows Vista, which is our most recent computer. If I wanted to use both my laptop with Linux and the desktop with Vista (if I can use both), would they both be able to sync to the iPod without interfering with each other?

The desktop has the largest hard drive, so that might be the best place for home for the iPod, if that makes sense.

I use Rhythmbox with Ubuntu and my iPod successfully. If you have other iTunes users on your network or whatnot, setting DAAP was pretty painless and I can see and share with iTunes users from Rhythmbox.

I have a new iPod touch, and couldn’t get any of the Linux iPod software to recognise it. I believe this is a problem with quite a few of the newest iPods. I ended up installing VirtualBox (note: you don’t want VirtualBox OSE, but the binary distribution of VirtualBox) and installing Windows XP on that. I then use iTunes to manage the iPod.

Thanks, but I don’t know about RhythmBox. It was was already installed, so I tried it, but I can’t even figure out how to import a folder. I select Music->Import Folder then select the disk is on, but I want to import a subfolder of one that’s shown. If I double click, it starts importing the folder shown, it doesn’t go down to where I can see the subfolder I want.

I tried to use RhythmBox, and it recognized my iPod. I copied songs onto it, but the iPod doesn’t recognize that there are any songs. It does know that the memory has been used.

When I told it I had an iPod nano, it wanted me to select which generation, but it only went as high as gen 4, and mine is gen 5. This might be part of the problem.