How to Alter Admin Privileges on Windows 10?

There are days when I’m okay with Microsoft and its products, and days when I’m not.

Today I’m not.

Why? Because half the programs I, personally, installed on the system won’t work right unless I run them with administrator privileges. :mad::mad:

I AM the administrator. I’m the only user of this bloody machine. I’m the only person with access to it. There are programs that I want to run as the administrator without having to go through the nonsense of right-clicking and telling Windows to run it as administrator.

How? It should not be so hard to find out how to do this.

For the record, Windows 10 Pro, 10.0.17134 Build 17134.

Do method #2 here:

Disable UAC and you’ll have a lot more freedom (and risk). Be careful.

More options you can disable if that’s not enough:

You can also right-click on a shortcut’s properties, go to the Compatibility tab, and check the box that says always run as administrator. This is less dangerous than the above method, but only works when you use that specific shortcut.

My UAC is already set to “never notify”.

I have set the one program that was consistently misbehaving unless I ran it as administrator to always run as administrator through the Compatibility tab. It’s just a bloody nuisance to have to go through it again every time I find another program that needs that permission.

Don’t mind me, I’m just feeling grumpy.

UAC Never notify wont blindly grant admin, it simply wont tell you that the program needs it
setting compat mode to run as admin is easy

I am pretty sure EnableLUA (method #2) is not the same as Never Notify, but it’s been a while. Still, try it and see? Just a quick registry change and reboot. If it still doesn’t work, I apologize… but it’s worth a shot.

This is what I do, set trusted programs to Run As Administrator without disabling UAC security for the entire computer.

I’m going to be a bit snarky, but if you have software in 2018 that doesn’t work correctly with UAC, UAC isn’t the problem here-- maybe cast a magnifying glass onto the developers of that software!

Basically, if it’s having problem with a feature introduced over a decade ago (and apparently never worked right with a non-admin account from NT4 to Windows XP either!), how many other decades-old bugs might be contained within?

I’d look for alternatives that are developed by conscientious developers.

I dunno, blaming end users or developers for Microsoft’s dubious security decisions of the 90s doesn’t seem fair either. It’s just a computer. It shouldn’t be so hard to use and require constant attention.

Computers can become pretty damn hard to use after they have been infested with malware that was able to run with full privileges on a single misadventurous click. That’s what UAC is attempting to control. Sure, it shouldn’t be hard to use a computer, but It also shouldn’t be so easy to run unknown programs.

I have to agree a bit with Blackey here.
Not being snarky, but you haven’t told us what specific programs you can’t get to work in Windows 10.

The people on this board have great & diverse sets of knowledge & experience. With the specific program names, it’s quite possible that someone here could either:

  • explain how to make adjustments so that it WILL work in Windows 10, or
  • identify programs that do the same function and will work with Windows 10.

So try giving us more specifics, and maybe someone can give you a better answer.

  1. UAC isn’t (and wasn’t) a “dubious security decision”. It’s saved millions of people from millions of pieces of spyware over the years.

  2. Software that doesn’t work with UAC enabled also never worked for a non-administrative user-- in other words, those programs were buggy before. (Probably lazily ported from Windows 98 to NT without considering the NT permissions system.) Microsoft didn’t make them buggy, they just exposed the existing bugs. UAC has no adverse effect for correct software.

Sorry I don’t agree with you.

It is the nature of my job that I spend a lot of time installing and using system-level and hardware-level programs, so UAC just isn’t appropriate for my work computer. Perhaps the OP is in a similar situation.

But apart from that, you remember that MS “solved” the problem of Vista being unusable by just whitelisting their own system programs? And that was a known vulnerability? And a big chunk of that vulnerability still exists in Win10?

I know why UAC exists, but I can’t say that MS has covered themselves with glory in the implementation.

Best solution, is to install and configure Hyper-V (included with Windows 10 pro) with a windows 7 or XP install just for these older programs that don’t play nice with Windows 10. It eliminates the annoyance of having to select run as admin every time, AND keeps the programs in a sandbox so they can only affect that virtual install (7/xp) and not damage your main OS (Win 10).

Sorry about the late response. I didn’t see there had been more replies and a couple requests for additional information until this afternoon at work, and then things got busy.

The program in question is Adobe FrameMaker 2017, so it’s not an old program. It’s all up to date. The issue started when I decided to install some plugins for it. These require putting DLL files into a particular folder.

The first problem was that I couldn’t move them into the folder until I ran File Explorer as an elevated administrator. This was annoying because (a) my account *is *in the admin group, although it’s not the elevated admin account, and (b) I could have SWORN I took ownership of every single directory on this machine, but maybe I didn’t and I’ll have to look up how to do it again and that irks me.

The second problem was that the plugins require registration. No biggie, I have the codes. But unless I am running FrameMaker as the elevated administrator, I have to enter the codes Every. Single. Time. I Run. the Program, because the registration doesn’t STICK unless you’re running as the elevated administrator.

Which also means I would have had to remember to right click and select run as administrator every time, except that I have updated this on the Compatibility tab (thanks for that, Reply), but I feel that I shouldn’t have had to do that in the first place and why does Microsoft make things so annoying? OK, yes, I know. Security and protecting users from themselves, but I’m fairly ept and I get tired of dealing with the safety rails meant for the inept.

I actually think this is an MS problem, not an Adobe one. The last Windows 10 update (1803) managed to semi-break the Save as PDF function back in April. Not sure if that’s fixed yet.

Did you ever try method #2 to turn off the EnableLUA key?

Not yet, since the Compatibility option worked. I may try it this weekend when I have some time. Work’s been rough the last couple of days and all I do when I get home is sleep. :frowning:

I do not remember that, and it sounds to me like a conspiracy theory. Microsoft (at least in the modern era) has never given their own software special treatment.

Have a link to an article?

If the folder is in Program Files, this is normal even if you’re a local admin. It’s an additional level of scrutiny because you can do a lot of damage to a system by moving a DLL file into Program Files.

If FrameMaker wasn’t coded by morons, they wouldn’t require putting plugins in the Program Files folder for both security reasons and usability reasons (aka avoiding the annoyance you’re talking about in this very thread.) Video games like Elder Scrolls Online get this correct; it’s inexcusable than Adobe does not.

Another FrameMaker bug. If it were coded correctly, it would put the files/settings in the correct location regardless of what permissions level the user has.

There’s nothing FrameMaker is doing here that can’t be done while also avoiding UAC prompts. Like I said above if video games, toy software!, like Elder Scrolls Online can get all this stuff correct, it’s inexcusable that Adobe hasn’t fixed these bugs in the last decade.

Sorry. Windows 10 doesn’t work like Windows 98 did. That’s “Microsoft’s fault” maybe, but FrameMaker inflicting this completely unnecessary pain on you for a full decade after UAC was introduced, that’s all Adobe.

FrameMaker actually has a special folder for plugins. It’s been that way since UNIX, the platform it was originally developed for.

For the record:
C:\Program Files (x86)\Adobe\Adobe FrameMaker 2017
C:\Program Files (x86)\Adobe\Adobe FrameMaker 2017\fminit\Plugins <— the directory for Plugins compiled into DLLs

Perhaps I should just call Adobe support about this. Or the company I bought the plugins from.