HTML Style Sheet weirdness ?

Wouldn’t believe it if it wasn’t right in front of me.

I have a .css file that controls a default webpage. Everything works… Except the settings for input.

<link rel=“Stylesheet” href=“Scripts/MainBlue1.css” type=“text/css” />
text-transform: uppercase;
font-size: 14px;

Well, not exactly. If I browse using http://localhost/test it works. If I use http://MACHINENAME/test it does not. Even doing it from the localmacine itself. The font-size defaults down to about 8px. Everything else in the style sheet works as expected using either localhost or MACHINENAME.

Just the font-size for the input is weird.

The font is not set anywhere else but the input style above.

Any ideas?

Could your browser have an override? Is it a PHP site that calls another CSS file from hidden code using an absolute link?

Can you PM me the URL? Or if not, try “inspect element” using Chrome, which should tell you everything that’s affecting the field.

It could be something as simple as your browser caching the old version of the stylesheet. What happens if you clear your cache or hold the shift key while reloading the page?

It’s not PHP. It’s all and jscript. There are not other .css files being called.

I’ve never used Chrome, the inspect element sounds interesting. I’ll try it, thanks
Can’t give you the URL. This is all for internal use at the moment and is in our DMZ.

First thing I did. Same response. Works fine with localhost but not with MACHINENAME.

Well now it’s working. Don’t know what did it though. I accessed it in both Chrome and Firefox and it was fine. Then tried IE and it’s OK now.

Really really strange. My boss tried it and it’s working on his machine now too. Both localhost and machinename. He didn’t clear his cache or anything. IE must have got scared when I loaded up Chrome :slight_smile:


Sloooooooooow caching probably.

I have this problem with my ISS/SharePoint setup - 45 minutes to update non-standard elements some times, when everything else updates immediately, leaving a lot of the content in an inconsistent state. Really pisses me off but nothing I can do about it.

I’ve had problems with Firefox not clearing the CSS cache unless I manually cleared everything. It turned out that cache was somewhat corrupted.