I can not delete some files

I’m having problems getting rid of some files on my computer. I’m using Windows 2000 Pro. The files I’m having problems deleting are Microstation/J.

What happens is that I’ve been trying to delete hundreds of files, most of which delete no problem, but a few say “Cannot delete 00113VD17: Access is denied. The source file may be in use.” The file has been there since August of 05 and is not being used. I have about twelve of these files that do not want to be deleted. I have tried to open them in Microstation and it says “File XXX not found.”

I have tried to overwrite them, but that doesn’t work, they will not move, or be renamed. Now I’m having to use those same named files for updating, but I can not get to them because of my problem.

Is there a way to get rid of these files? They are starting to annoy the hell out of me.

Did you take the correct steps of first uninstalling the program that uses these files first? When a program is installed, it creates registry entries, and if your method of removing a program is just to delete the directory its in, then these entries are still there, some of which could be telling your system how to handle these files.

Of course, sometimes you uninstall it properly and it still does this. Have you tried logging in as a different user? Sometimes, file associations are based on the user, so try logging in as administrator. Not as a user that has admin privlages, but with the actual username administrator.

I’d love to get rid of Microstation, but I’m pretty sure my boss wouldn’t like that. It’s also only some files, out of the 3-400 I deleted only 12 or so are doing this. They are also not part of the program, they are more like Word files, so they shouldn’t be in the registry.

I haven’t logged on as anyone else since I can’t but I would imagine that it would do the same thing. I will try it though and see what happens.

In some versions of Windows, you can CTRL+ALT+DEL, end the process called explorer.exe, delete the files you need gone, and then start a new process called explorer.exe. Explorer is the GUI shell that enables most interaction with the file system, so you won’t be able to do much other than use the task manager. Deleting the files needs to be done in a separate command-line window. So, in order:

  1. Start->Run->cmd (brings up a command prompt)
  3. End process on explorer.exe
  4. Use DOS commands to navigate to the files you want killed, and delete them*
  5. Type “explorer.exe” at the command prompt and/or click “new task” in the Task Manager
    • I realize not everyone knows DOS commands. You only really need to know that “cd” is change directory and “del” is delete, but if you need more precise instructions I can help.

I do know DOS, and I tried this but got an access is denied. Hey, you are in Silver Spring, I should just have you come over and do it. :smiley:

I get that problem sometimes here when I’m deleting off the server here. Write down what won’t delete, then restart the computer. Usually that’ll do it. Otherwise, restart in Safe Mode and try it then.

You should visit sysinternals.com - the greatest windows freeware in the world. Some utilities from here are actually referenced in solutions in Microsoft’s knowledge base.

Some that might help you :
Schedule files to be deleted at system bootup, particularly usefull for stubborn malware/ adware programs that show as “access denied”

Ever wondered which program has a particular file or directory open? Now you can find out. Process Explorer shows you information about which handles and DLLs processes have opened or loaded.

This didn’t help, I keep getting an error when I try and use movefile. I also tried to start in DOS and it would only let me go into safe mode without a prompt.

It’s becomming quite annoying if you’ve ever tried to move a ton of files only to have one in the middle not move.

I have found a strange work around though. I can move the folders that the files are in, but not the files themselves. So I moved the folders, then just moved the files I needed back out. I hope I never have to see this problem again, but those pesky files are still there.

Try this :