IE 6 access problem (HTTP Error 401.3)

Here is the configuration:
Windows XP Professional
Internet Explorer 6
All Critical Updates and Patches applied
All cookies and temporary files deleted
No viruses found with Norton Antivirus using up-to-date definitions

Here is the problem:
When attempting to access a particular password protected site (here), when hitting the button labeled “Course Login” instead of a dialog box asking for the password, this error message appears:
“HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource. Internet Information Services (IIS)”
Only one particular PC is having this access problem. All other PCs that link to the site get a password dialog box.

Other information:
This is actually my son’s problem. He’s away at college and the site is for class notes that he’s supposed to read and print off prior to coming to class. I can get to the dialog box and so can all his classmates, but he can’t. Interestingly, when I cancel out of the password dialog box, the error message appears that my son is getting right away in place of the dialog box.

Any ideas?

Your answer is probably in this thread. It is a glitch with MS-IE6-SP1. There is a patch but it did not work for me. Reinstalling SP1 resolved it for me.

Thanks sailor. We’ll try that to see if it resolves the problem.

No luck. Re-installed service pack 1. Same problem.
:confused: :mad: :frowning:

1st, make sure that you’ve shut down and restarted the computer. There is a kink in IE and Outlook Express that sometimes kicks in during a session. And many users have the habit of leaving computers on all the time.

If that doesn’t solve the problem, then reinstall IE entirely. Just installing the Service Pack isn’t likely to solve the corrupt problem. About a year ago I had a similar problem with IE. It’s a pain to reinstall the entire thing then get all the patches, but it is, on the other hand, free.

SP1 is the entire thing, not a patch. I just reinstalled it and it is a new install. Did you try the patch first? I tried the patch and it did not work for me but the new install did. maybe the patch will work for you.

This could be due to an IE security setting.

Got into Tools / Internet Options and click onto the Security tab.

Click on the “Internet” Web content zone (icons at the top) and it’ll likely show that the security level is “Custom”. Click on the “Custom Level…” button and scroll down to the bottom of the list of options this beings up.

There should be four options under User Authentication / Logon. The default setting is “Automatic logon only in Intranet zone”. If “Anonymous logon” or “Automatic logon with current username and password” this may cause the problem you’re experiencing.

Set the option to either “Automatic logon only in Intranet zone” or “Prompt for user name and password” and give it a try.

I’ve replicated the observed behaviour by changing this setting, so it’s worth a try.

sailor, could you point me to the patch? I can’t seem to find it.

Armilla, I’ll have him check that too.

Thanks everybody. When I run out of ideas I know that if I come to the SDMB there will be nearly unlimited additional ideas.;en-us;831167 is the main page describing the origin of the problem.

So it seems that wininet.dll is messed up when you install this update and it may be a simple issue of restoring the old Wininet.dll. At any rate it links to the patch which should fix the issue (but it did not work for me):

In case it helps: I am running WIN98SE & IE6-SP1 and my wininet.dll is version 6.00.2800.1106, dated aug 29, 2002 and is 589824 bytes.

In the laptop where I did not apply the 832894 security update : WIN98SE & IE6-SP1 and my wininet.dll is version 6.00.2800.1106, dated aug 29, 2002 and is 585728 bytes

I am suspecting that just restoring the previous wininet.dll might solve the problem

Thanks sailor for your patient and thorough assistance. I appreciate it. I hope this works. I’ll be back with the verdict.

Jury foreman, would you please read us your verdict?

Action of re-setting the IE Security settings: failed to correct the problem
Action of installing the patch: failed to correct the problem.

Sigh. And previously the action of reinstalling SP1 also failed.

The current plan is to download Firefox to see if that will get him into the site. This is probably the first time I’ve ever been at wit’s end with a Microsoft product. I’ve been one of those folks that never could understand the vitriol directed at Bill and company. Now I can somewhat understand.

Well, just wait until you have spent some hours messing with Firefox only to find out it doesn’t get you in either!

I did some Googling and found some indication the problem is probably at the server side which does not have the machine listed as authorized.


I was worried about that too. Trying Firefox was a last-ditch effort only after all the other attempts to repair IE had failed.

I just received an IM from my son and he said that he downloaded Firefox and got into the site with no trouble at all.

In my son, I may have unwittingly created another “if-it’s-Microsoft-then-it-is-evil-corrupt-and-unreliable” bigot.

But he can at least get at his class notes now.

By the way sailor, I don’t want you to leave you with an impression that your help was not deeply appreciated. It was.

And thanks also to all the others who made suggestions. These problems are quite frustrating. I’m thrilled to have someplace like the SDMB to post them.