Importing mail from Outlook to Mozilla Thunderbird: problem

I’ve been using Opera as a backup browser for a while, while continuing to do a lot of stuff on IE6. I tried using Mozilla on my old computer, but for some reason it didn’t want to play ball, and the downloads were incredibly slow. Now that i have a new computer, i thought i’d give Firefox and Thunderbird another try. Firefox is great, and i especially love the extensions. Thunderbird also seems to be a great mail program, and i’ve pretty much decided to give IE and Outlook the old heave ho.

Before i do, though, i’m having a small issue with Thunderbird. It’s not a deal-breaker, but if i can fix the problem it would be good.

I imported all my mail archives into Thunderbird from Outlook (not Outlook Express), and everything seemd to be hunky-dory. The only hassle is with messages that have attachments. With those messages, the attachments come through fine. However, any text in those messages is imported not as regular email text, but as an attached file called “Part 1.1.” I can read this file by opening it in WordPad or Notebook, but it’s a little annoying. Does anyone know why the email text is converted to an attachment on these emails alone? And is there any way i can stop this from happening?


I’m gonna give this a bump and see if any of the weekday Dopers can help.

I’m not an Internet email expert, but I’ve got a pretty good guess on why and what you might do about it. I wouldn’t take any of the following as gospel, but it should give you an idea what’s going on.

Internet e-mail messages with attachments actually come in a multi-part format. Generally, the first part is the text message, the second part is the first attachment, etc. Each part has a MIME-type associated with it to give the mail reader some idea how to decode the part (e.g., JPEG data is decoded from mail text back to raw binary image data). There’s usually no decoding necessary for text message parts, but they have to have the right MIME-type so that the mail reader knows that.

For whatever reason, the text message portion of those emails with attachments imported from Outlook do not have the normal text/plain MIME type needed to show them as text (or some other MIME type Thunderbird would know how to deal with), so Thunderbird will only let you extract that part and view it with some other program.

Here’s what you might do to fix the problem assuming all of the non-displayable parts really are plain text. This gets a little fuzzy because I don’t have a good example to work from, but I’ve done similar things with Mozilla; hopefully you have the technical background to pick up what I’m laying down and fill in the blanks.

  1. Highlight one of the messages you’re having a problem with and select View->Message Source from the menu. You should be able to pick out a line that says “Content-type: xxxxxxx/xxxxxx” shortly before the message text. That xxx/xxx bit will be the incorrect MIME type we’re going to try to correct, so remember it/write it down/whatever.
  2. Close Thunderbird.
  3. Find the Inbox (or other mailbox you want to change) file. It should be somewhere below C:\Documents and Settings<username>\Application Data\Thunderbird(?).
  4. Make a backup of this file, like copy it to another directory; hell, you might want to back up the whole directory. You know, in case this doesn’t work.
  5. Open the mail file with your handy-dandy text editor. Do a search and replace on “xxx/xxx” above and replace it with “text/plain”.
  6. Save your changes, open Thunderbird back up, and check the message from step 1 to see if that did the trick. If so, hopefully the search and replace got all the other messages, as well; otherwise, you might have to repeat the process for those messages. If it didn’t work, restore the backups from step 3 and I guess I didn’t know what I was talking about after all.

Thanks for the advice.

Your strategy worked, except that it also converted the attachments to plain texts, meaning that they could no longer be opened. Given a choice between the two, i think i’ll take having the message in attachment format, because i don’t want to lose the attachments.

Thanks again.