iTunes help

Mrs. L.A. bought a CD I’d like to put into my iTunes library, and I’m having a couple of problems. First, my CD/DVD drive doesn’t work. So I got out the old PowerBook G4, put the new battery I’ve had sitting around in it, put the CD in it, and connected it to my MacBook Pro.

I opened iTunes on the MacBook and went to File|Add to Library and selected the songs on the PowerBook’s drive. It showed a progress bar and eventually finished. Here’s the next problem: I don’t see the songs in my library. I tried dragging the folder into the iTunes window. That didn’t work. I copied the files to my MacBook and tried File|Add to Library and dragging from there. No joy.

I haven’t used iTunes in years, and there have been several updates to it. It doesn’t look or work like the version on my PowerBook. So how do I get the songs into iTunes? If they really did upload the first time, where are they?

iTunes should recognize that there’s a CD in the drive and let you “import” it. Then the audio is converted to MP3 or AAC or another format that iTunes can play.

It’s been a while myself, but if I remember correctly, that progress bar you saw is just iTunes querying the internet to attempt to figure out what the CD is (and so, tagging the title and tracknames). As iljitsch says, you still need to tell iTunes to import the disc and transfer everything to your drive.

iTunes should recognise there’s a CD in the drive and let me import it. It should recognise that I have a folder on my computer and let me import it. File|Add to Library or dragging the folder to iTunes should import the files, as directed by the Help topic. It doesn’t.

The last few updates have made iTunes completely unusable IMHO.

I have moved to using the Amazon music app, which (so far) is working much, much, much, much, much, much better.

I gave up on iTunes when they told me I needed an Internet connection to listen to music files that were already on the device. I think they are trying to get everyone to use their “cloud” services.

Try going into the iTunes preferences and make sure the option to import a CD when an audio CD is detected is checked properly.

I don’t have a checkbox. I have a dropdown menu under Preferences|General. ‘Ask to import a CD’ (when a CD is inserted) is displayed. Under Import settings, AAC Encoder is selected. The other options in the dropdown menu are AIFF Encoder, Apple Lossless Encoder, MP3 Encoder, and WAV Encoder. Error correction is not checked.

I’ve given up on iTunes. I downloaded some CDs to my computer and they are there on Windows Media, but unable to get them to iTunes. So I just use Windows Media Player.

:dubious: What are you talking about? You don’t need to be connected to the internet to listen to music you have on your phone.

Did you import them to your computer as Windows Media (.wma) files? If so, well that’s why iTunes won’t see them…

I just imported them. I guess I did, but I thought that the music I had on the computer would be synchronized to all music players. Apparently not.

I meant checkbox kind of loosely. Since I’m not using the same version of iTunes as you, I can’t be sure what the preferences window looks like.

Have you tried looking for the iTunes Music folder on the Powerbook’s drive?

I just re-read your original post, and I see I misread it. Did you try importing the CD to the Powerbook? Or were you just trying to use the drive on the Powerbook as an external drive for your Macbook?

The music is not in the Music folder. I don’t actually know what the name of the folder is. I open the Macintosh HD folder and type iTunes into the Search box and my music tracks show up. I enter the name of the band, and only one song, which I downloaded or bought individually a while ago, shows up. The album I tried to upload from the CD is not there.

I did not try to import the file into iTunes from the PowerBook. (It has a rather old version of iTunes that was better than any of the updates.) I put the CD into the drive and iTunes opened up on that computer. I opened iTunes on the MacBook and did what I said in the OP: Opened iTunes on the MacBook and selected the CD on the other computer.

The CD drive on the MacBook isn’t working, so I’d have to break out the other computer. But then I’m back to the OP. Also, I don’t have the ‘CD button’ mentioned on the page.

I tried this:

As I said, it didn’t work.

Yeah, I’m not surprised this didn’t work. I’ve tried to reload an operating system that way, and that didn’t work either. If I were you, I would rip the CD into iTunes on the Powerbook, and then transfer the ripped files to the Macbook.

I’ve had a lot of Macs and the optical drive has failed in almost all of them. I use an external optical drive, and I’ve never had any issues with them. If you think you’ll be trying to rip files from CD/DVD now and again, get an external drive. They’re inexpensive.

Here’s a cheap one on Amazon:

It doesn’t sound like you have actually imported the files to your hard drive. Your set-up is a bit confusing with connecting one laptop to another laptop and then ripping from one to the other?

Why don’t you just import the files onto the PowerBook and then move them onto the MacBook? What am I missing here?

I’ll try that.

I might do that. I’ve been meaning to have the onboard one replaced, but I missed my window in December. I need my computer for work. I suppose I could just use the PowerBook until the MacBook is repaired. It would be nice to be able to play a DVD on a trip without having to bring another piece of hardware. (I haven’t figured out how to access stuff from Xfinity yet.)

I have a PowerBook and a MacBook. They can connect to each other wirelessly, and one can access files from the other. On my MacBook, there is the folder that contains the songs. I can play the songs on the MacBook’s iTunes – without being connected to the PowerBook – by double-clicking on a song in the folder on my MacBook’s desktop.

OK, that’s weird… I opened iTunes on the MacBook (earlier today) and tried to import the CD from the PowerBook. In attempting pidgeon92’s suggestion, the files are actually on the iTunes on the PowerBook.

This doesn’t surprise me either. I was wondering if this was a possibility.

As for watching DVDs on a trip, if you have the hard drive space it’s easier just to rip them to your Mac (using the aforementioned cheap external drive) before you head out. That way you won’t have to deal with taking along the physical DVDs. I highly recommend Handbrake if you just want to rip the movies or Mac DVD Ripper Pro if you want to rip everything on the DVDs.

OK, this is what I did:

I re-imported the CD into iTunes on the old computer, then closed iTunes. Next I went to Macintosh HD on the new computer and connected to the MacBook. I went to Macintosh HD (on the PowerBook) => somewhere I can’t find again. Anyway, I copied the mp4a files from there into a folder on my desktop. Then I went to Music (on the MacBook) => iTunes => iTunes music. I found the folder that has the album one song I’d previously downloaded. I dragged the folder from my desktop to the Artist’s folder. I got a progress bar saying the files were being copied, and did I want to replace the folder and the one song. Now I have the entire folder in Macintosh HD => Music => iTunes => iTunes music => artist’s folder, and the 13 tracks are in the album’s folder.

When I open iTunes, the songs are not there.


I clicked on the album in iTune’s weird new format and there was the one song I’d downloaded a year or so ago. I opened the folder on the MacBook’s desktop and dragged the songs into that folder. I think it worked. It seems to have worked.

What a chore! I liked it much better when all you had to do was import.