iTunes skips when I'm using the Internet

It’s driving me nuts! When I click on any link, or even when Eudora checks mail, iTunes skips until the page is loaded or the mail is done being checked. There’s some small comfort in knowing that this happens to a few friends of mine as well so at least I’m not alone, but none of us knows why this happens or how to fix it. Actually, I don’t really care why it’s happening; I’d rather just know how to make it stop. (Yeah, yeah, I know I could make it stop by switching to a better media player but I just figured out how to get iTunes to do most of everything I want. Except not skip.)

Any suggestions?

I’ve had that happen and assumed it was an issue with insufficient processor power/RAM/something such that my computer just isn’t good enough to do both things at once. Sorry that I don’t have a solution; I wanted to bump this a little and tell you you’re not the only one, at least.

Does that help?

Hmm…I’ll let you know in a few minutes.

Alas, no. :frowning:

A friend of mine claims to have fixed this problem by moving his sound card to a different PCI slot. I don’t recall the details but here’s another guy who seems to have fixed the same problem in the same way:

I’ve seen two things that can cause it. One, aggressive video drivers that hog all of the bus bandwidth when they update the screen. This can often be fixed by changing the settings for the video driver. Two, insufficient RAM combined with an IDE disk interface that is operating in PIO (programmed I/O) mode. Get more RAM and, if possible, setup the IDE disk interface to operate in DMA (direct memory access) mode.

Thank you. I have no idea what a sound card looks like or what a PCI slot is, nor do I have any idea how to translate “IDE disk interface that is operating in PIO mode” into English. But at least I now have a point at which to start my lengthy education as I try to figure out what it all means. I guess I’m about to learn something tonight. Much obliged to you all.

This is going to sound wierd and counterintuitive, but I had that problem with Rhapsody, and it went away when I upgraded to IE7. I run XPhome.