Java problem since upgrade to Firefox2

For quite a while, people were telling me I should upgrade from FF1.5 to 2.0. I kept resisting, but then I started getting these attempts programmed by the Mozilla people to ensure I did it. I still resisted, but …

After long months of waiting, I finally got someone to set up my new computer, and I wanted no problems in transferring settings from one computer to the other, so I allowed the upgrade to happen. Now, suddenly, Java isn’t working. What’s more, Java isn’t working in the FF2.0 on the new computer, either. I even went to and downloaded and installed the latest version. Still no joy.

Hallllp, please? Pretty please? There are sites I w/a/n/t/ need to see that I can’t, now.

Java, or Javascript? Despite the similar names, they are totally different things, so installing the latest version of Java from Sun will not help with Javascript problems. First thing to check would be Tools/Options…/Content.

I checked it repeatedly. And tried various combinations of things in it. I currently have absolutely everything authorized, except for giving the site where I experienced the problem blanket authorization to do everything.

It made no blinkin’ difference, alas.

OK, what site is it?

I have to assume you’re using a Windows box; since I run Linux, I don’t have much (concrete) advice. However, I’ll also assume that either (1) you’ve installed the wrong thing, or (2) FF isn’t finding the JRE plugin.

Have you followed the steps in the FF help/FAQ?

The specific site is - when I try to use a link to open a client site as a BigCrumbs member (so any offers will apply, and purchases can be credited), I get this message that Java needs to be enabled.

Having had rotten luck in the past with help from the Mozilla site, I frankly didn’t even think of trying anything from there. I like Firefox okay (was a devoted Netscape user all the way back to the beginning), but …

It will be later today before I have a chance to try to do whatever they suggest. Gotta go do other stuff for some hours now. I just wanted to get my problem up here (where the best help anywhere is available) :slight_smile:

Well, their suggestion simply goes to Sun’s Java site for a download (supposedly, you can use XPInstall from within FF). Following it, I see that the default is version 6; that may be a problem – of course, things should be backwards compatible, but it doesn’t always work out that way.

Sorry I can’t follow any further, as I’m only presented with Linux downloads.

Real Life prevented my return until now. Not long after I logged off here yesterday, I suddenly began getting nuisance calls (the ring, you say hello, they hang up, variety). After half a dozen or so, I took time for a chat with my phone service provider. And then later on going to the store to buy stuff. Why do these things always wind up costing money? Usually far more than any budget allows?

I just now used the link above, and when I clicked to download, it checked my system and said “Congratulations! You already have the latest version” OWTTE

So then I went back to BigCrumbs, logged in, and tried to use a link to a vendor site. And got the same message I’ve been getting. It does say JavaScript. Based on some comments above, I gather that isn’t necessarily the same thing?

Can anyone else help me? This is getting really frustrating. Everything worked perfectly until I installed FF2.

Yes. Stop trying to update Java - it has absolutely nothing to do with your problem. On a really basic level, Java and Javascript have nothing to do with eachother other than 4 letters.

So back to the beginning…

You go to this Web site and log in.
You see a link that says “click here to go to another site”
You click the link and the browser says “Javascript error”

Is that it?

What’s the error, exactly?

What is supposed to happen when you click on the link?

I go to the site (shown above), login, and attempt to go to a vendor site (in another tab, as usual). I then get a message saying:

>>>If you did left-click, then you may not have JavaScript enabled in your browser. JavaScript is required to ensure that your account is credited.

To enable JavaScript: <<<

It gives instructions for enabling it, which I checked, in Tools: Options. According to FF, it’s all enabled. But it’s NOT working.

Ok so I logged in and made an account.

I was able to very easily click on a vendor’s site link to get to another site. It opened up a new window with a page that said:

Now, if I RIGHT click on the vendor link, and choose “Open in a new tab” I get:

So are you left clicking and letting sites open in a new window, or right-clicking and choosing “open in a new tab”?

Because you say:

I have Firefox 2 and there is no opening in a new tab for vendor sites - only clicking and letting it open in a new window.

Sorry - I have my mouse buttons reversed, and I forgot to translate. But I’m doing the very same thing I’ve been doing since I joined - and that’s nearly a year ago. I never got this message before.

So are you actually right-clicking?

If so, you have to stop. Start left-clicking.

If it worked ok in FF 1x, it was a fluke. It says right there, in the instructions right from the company, that you HAVE to left-click. If you left-click and you still have a problem, THEN there’s an issue.

If you right click, and it clearly says “you gotta left click” then the issue is not with the site or the browser, it’s with the way you’re using it.

So are you right clicking or left clicking?

Sounds like I useta left click, and forgot I had done it that way. :smack:

Hand me the stupid hat, okay? :o

And thanks for your patience.

So right now, when using Firefox 2, are you left-clicking or right-clicking?

I am confused. Is the problem “fixed” (you are now left-clicking where you had previously been right-clicking and a new window opens and you go to the vendor site) or is it “not fixed” (you are left clicking, always have been left clicking, and you still can’t get to the vendor site)?

If it’s “fixed” then er…you’re welcome?