Java problem with Firefox 13.0

I apologize in advance if this has been asked before. In fact, I seem to recall a thread recently that might have covered the same question but I can’t find it. I’ve even searched using Google but no luck.

In any case, my question is this:

Since my most recent update of Firefox (to 13.0), I can’t seem to get Java working properly (or maybe not even at all).

As a specific example, if I go to this game at, in the same place where I should see the chessboard (where the game should be displayed and played out), I get a message saying “a plugin is needed to display this content”. Directly underneath this message is a hyperlink saying “Install plugin”. When I click on it, after a few seconds I get another message, this time saying “no suitable plugins were found”. No further options or suggestions are given.

I’m sure this has a simple solution, but ‘simple’ for most people translates as ‘probably impossible’ for me. Can you help me, please?


Forgot to say that I am using an iMac with OS 10.5.8.

I’ve got no experience with Macs, but in FireFox you should try clearing cache under “Options” “Advanced” “Network” - if that doesn’t work, try the Mac equivalent of deleting all Temporary Internet Files, if that even exists as an option somewhere.

ETA: Close browser after clearing cache. If you’re going to delete Temp Internet Files, do that with browser closed, then restart.

I don’t know about Macs either, and Java (including the page you link to) is working fine for me in FF13. However, what I would do first, in your situation, would be to download a the latest version of Java, and install it (with FF turned off).

I went to the website to check where you should find it, but it seems that Macs have their own way of providing Java updates:

I suggest that you try that (if voltaire’s advice didn’t solve things).

Thank you.

Sorry for disappearing after my OP - something unexpected came up and I needed to leave.

I actually tried downloading the latest Java for Mac; evidently I am up to date.

I will try the ‘cache clearing’ option.

Thanks again!

Well, did it work? As someone who tries to help others with computer problems, I like to try and keep track of recommendations that work.

Alas, no.

But, everything seems to be fine if I use Chrome - so that’s what I’ve been doing.