Why doesn't Java work in Firefox for me?

Running Firefox in Windows XP. Pretty much any time I load a site that has a Java application, the app simply doesn’t load. I don’t get an error message of any sort, just a blank spot on the screen where the Java app should be. Examples of sites containing applets that will not load are the NY Times crossword puzzle site (members only or I would link to it) and the Baby Name Voyager site at http://babynamewizard.com/namevoyager/lnv0105.html. But it’s not just those two; pretty much any time I want to run a Java app, I have to fire up IE, and it’s very annoying.

Java is enabled in the Options dialog box in Firefox; I checked. So what am I doing wrong?

Try this. How do I install Java?

CMC fnord!

To be exact, install Java using XPInstall.

OK, I did that, and there was a slight improvement in that now I see an “applet loading” screen while the applet is loading, but then the screen just goes blank again, just as before. Any additional thoughts?

Now, ya got me stumped.

Did you close and restart Firefox (I’d even do a system restart)?

Yeah, I restarted the browser and then restarted the entire system, and still no dice. Java fires up, the applet starts to load, and then… blank screen. Sigh. Thanks for the help, though.

Does a Java icon appear in your Windows system tray(next to the clock somewhere)? The icon will look like this: http://java.com/im/logo_scurvejava.gif . If so, right click the icon and click on “Open Console”. Are there any error messages?

Something to watch out for that will give these same symptoms is a Java app written for Microsoft’s version of Java. They altered the JVM and people wrote code specifically for it (we have an app like this here at work), which means you must use the MS JVM to allow the program to run.

At work I switch the setting in my browser back and forth to select the MS JVM or the Sun JVM (I have both installed), depending on which app is being run.

I doubt that’s the problem, given that J++ was discontinued more than 5 years ago.

I have the same problem on 98se. Can’t get any site to play java on Firefox. Grrrrr

I’m not talking about J++ (which was an IDE), I’m talking about the MS JVM.
For those not familiar with the dispute between Sun and Microsoft and the JVM, here is an excerpt from the following article:


"The two keywords Microsoft added to its Java language implementation are:

The three compiler directives under discussion were:

Gosling and Sun argued that these Microsoft-specific keywords and directives result in incompatible Java bytecodes, which in turn generate exceptions on any non-Microsoft JVM. Gosling held that this violates the Java Language Specification (JLS) requirement that a compliant JVM must compute the same result for the same Java code as the reference JVM, Sun’s JVM. Gosling also testified that the addition of the compiler directives violates the JVM Specification (see resources for online versions of both specifications) by resulting in previously undefined attributes which affect the semantics of the containing class files. "

By J++, I meant the MS-specific Java extensions. AFAIK, after the suit was settled the Microsoft was not allowed to distribute their JVM.


“Recognizing the need to provide a smooth transition for current users of the Microsoft® Java Virtual Machine (MSJVM), Sun Microsystems and Microsoft have agreed to extend Microsoft’s license to use Sun’s Java source code and compatibility test suites. This extension allows Microsoft to support the MSJVM until December 31, 2007, providing customers with the ability to transition from the MSJVM on a schedule and plan that is most effective for them.”

The suit was finally settled in 2004. Sun allowed MS to continue supporting the MSJVM (for a small fee of $700million).

Microsoft was willing to pay because people coded their apps for the extensions MS made to the JVM.

This is why apps written for the MSJVM do not always work when the user has installed and is configured to use one of the standard JVM’s from Sun, IBM, BEA etc.

Okay, for absolutely no reason that I can discern, Java is now working. I suspect it had something to do with the reinstall I did yesterday, although why it didn’t work after I rebooted yesterday, but is working now, I have no idea. Thanks to everybody for all the help.