Jumpy (optical) Mouse Problem

Did a little searching on this and couldn’t quite find the issue I’m having.

I just got a Dell Vostro 1000 AMD laptop. Refurbished for under 500 bucks! Not bad! But that isn’t the problem.

The problem is I have a Logitech MX610 Left Handed mouse with the Setpoint software version 4.00.121. Like most laptops these days it has a touchpad which appears to use Dell Touchpad software. Also, I’m using XP home edition, SP2.

Everything works just fine, both external mouse and touchpad until the computer is, uh, doing stuff. Not really even tough stuff. Stuff like transferring a large file to or from this computer over the network. Then my external mouse is rather jumpy and virtually unusable. But my touchpad seems unaffected. No jumpiness at all.

I’ve tried closing out the Setpoint software. Still jumpy. I tried, in the Dell Touchpoint software, “Disable touchpad while USB mouse is connected.” Still jumpy.

Then I ran out of ideas and hoped the internet would be my savior.

Any thoughts?



Hmm, weird. Only thing I can think of is that perhaps there is a later, and/or better driver for the Logitech mouse. Sometimes that happens even with devices that are new. Worth going to their website to find out.

What is the surface you are using the optical mouse on? I bet if you use a new white sheet of paper it works fine.

The MX610 should be cordless, no? Perhaps your network is interfering with the signal, which would make sense if it happens while transferring over the network. I had that problem with a poorly shielded ethernet cable. Try moving the transmitter dongle to a different USB port perhaps away from the ethernet.

I was going to say that, but surely if it was the mouse surface that was the problem then it would be jumpy even with the PC not doing any other tasks?

FWIW I had no end of problems with my optical mouse randomly jumping to a corner of the screen, which I traced to using a mousemat with an area of red in the design. Red mousemat plus red laser = epileptic mouse.

Have you tried jumping on one foot, throwing goat feathers in the air, and chanting verses nine through eleventeen of Hey Jude backwards?

I think that’s what did it for me, though there were lots of very helpful suggestions in a similar thread: Cordless mice freezes – normal?.

I regret that I used the word “mice” in the title, probably throwing off your search.

The mouse seems to work fine now [knocking on wood/chanting/hopping/etc]. I tried everything in that thread, but I can’t say which was the one that did it. Everything from different port, surface, mouse, batteries, distance, brand of Scotch…

As for possibly not/possibly… I eventually went back to my old mouse pad, mainly for habitual/sentimental reasons. It’s a Steal Your Face with lots of red. On the other hand, it had well over ten years of accumulated pet hair and other detritus (not sticky-filthy, but not quite pristine), a bit of which may have interfered with the optical sensor. I’d moved to a clean (paper) surface for a bit, but when things calmed down and the mouse was working as I expected, I went back to this pad.

I wish I could point to a particular solution, but about all the help I can offer is to suggest trying everything. That is, nothing seemed to work when I tried isolating the solution (i.e., controlling for variables), but for whatever reason (voodoo) it’s now working fine.

Good luck!


Every time my logitech optical goes jumpy on me it’s a battery problem. Goes away as soon as I change them out.

Thanks for the replies!

I’m using the same mouse pad I’ve used for several years now. And there are no problems except when the computer is “working.” I mostly just notice it when files are being transfered as that can take a while. It also happens when apps are loading, but as that lasts a few seconds at most it’s not an issue.

My mouse is wireless as is my network. I pretty much always have streaming internet music going during the day, and it doesn’t seem to interfere at all. Maybe it isn’t transmitting enough data to interfere?

As for the batteries, I’m sure it isn’t that. Setpoint has an awesome (sarcasm) feature that pops up a message letting me know my batteries are low. I have no way to turn this “feature” off. The best part is that I get at least 2 more weeks from the same batteries as the stupid message is popping up.

I’ll check out Rhythm’s thread and see if that helps.

Thanks again,


Ok, on further testing:

I ran some intensive programs locally, no jumpiness.

I copied a large file from onew spot on my local hard drive to another spot on my local hard drive. No jumpiness

I tried switching the mouse USB sensor (it is just a little thumb drive looking sensor, not a base with a cord, if that makes sense) from the back port to a side port. Still jumpy.

So, it seems that this is only occurring when I transfer files over my network. It also is happening when I run queries over my network. Being that I’m a database programmer type and some of these queries can take several minutes to run it can be annoying.

It’s not the end of the world to use my touchpad in these situations. I just wanted to post my latest findings in hopes that someone has a cure to this debilitating illness.

Thanks again!


When my optical mouse goes jumpy, I usually find that it’s picked up a hair, which is stuck in front of the red light on the bottom. Blow the hair away, and it’s fine.

It doesn’t sound like this is your problem, but I thought I’d post it in case someone with a similar problem finds this thread by search.

Open it up and blow the dust, hair and other accumulata out.

So it’s clearly an RFI problem (radio frequency interference). Can you change the channel that your network card is set to? Also, I know this won’t make you happy, but you could always switch to an optical-but-USB-corded mouse.

I have a somewhat similar problem, only with a corded optical Microsoft mouse. In the last few weeks, it’s developed narcolepsy. It’ll suddenly fall asleep, snooze for half a minute or so, then wake up again. It’s driving me batty. Of couse, I’m running Windows 98 SE, so I suspect the true solution is the usual, “Dude, get a Mac!”