Linux issue: “server not responding” msgs starting to appear in DreamWeaver

I have an Ubuntu Server on my small network that acts (among other things) as a Web page testing server. I have DreamWeaver set up to connect to our remote host for putting operations, and the testing server is our local Linux machine. It worked great, as testing a page was instantaneous over the LAN.

Then something —I have no idea what—changed and now, when we test on server or try the “test” button on the site configuration menu, we get ten to fifteen seconds of “Server Not Responding / connecting to server,” then it connects fine.

The server pings fine and I can connect via an OS (both Mac and PC) fine. It’s just that we went from instantaneous connection to an irritating delay. Any idea where I start diagnosing/fixing this?

Here is a bit of background on the machine. I’m sorry I’m not sure what’s relevant — if I forgot something, please let me know, and ignore anything that’s superfluous.

It recently upgraded to 2.6.24-21. The upgrade went fine, but I had to reinstall the LAN drivers. The Linbox is assigned an IP via the router’s (Linksys 310N) DHCP Reservation Table, based on the Linbox’s MAC address. I don’t believe I’ve set a static IP on the box (/etc/network/interfaces is generic and unmodified). I’m using ProFTPD and WebMin, but mostly with default settings.



Are you using a DNS name or ip address?

The DNS lookup could be taking the time, so you may need to create a local hosts entry.


In the FTP Host: box, I’m using the IP address (

I’ve never created a local host before, nor do I think I accidentally deleted one.

When I browse to the pages (e.g., they come up instantly. Also, when I use Windows File Explorer to look at the drives (both the file sharing area and /var/www) things are instantaneous.


Sounds like a DreamWeaver issue, then. Have you accidentally set a proxy or something?

Does Dreamweaver launch it’s own browser or fire up IE/Firefox/whatever? Maybe there is a proxy configured there (or proxy autodetection is trying to find a proxy first).

You could try installing WireShark and sniffing the ethernet traffic to see what is going on.


Again, thanks for the help.

I doubt the problem is in DW – it first came to our attention when the Mac was tryign to connect, then I verified (as in, wachyoutalkingboutWillis) on the PC; both had a similar delay that was not present before. I will, of course, be double-checking DW configurations anyway.

I’m taking a look at WireShark – I may need to know a bit more about networking then I do at the moment…

Problem solved!

Per the proFTPD FAQ:

I went to the ProFTPD Server module of WebMin, then to Networking Options. I changed two entries:
[ul][li] Do reverse DNS lookups of client addresses? (From default to no)[/li][li] Lookup remote Ident username? (from default to no)[/ul][/li]I then restarted ProFTPD and voila, it worked like it did before!

Any idea why the issue just arose? It really was working fine before (whatever) changed. Since I was switching from defaults, I’m pretty sure I hadn’t done anything in the meantime (though by “I”, I mean I didn’t do anything directly — I did update the kernel, etc.).

Anyway, I’m glad things are working – again, thanks!

Well done. It was not clear to me (because I have never used Dreamweaver) that this was affecting FTP connections.

As to what has changed - maybe your updated system has changed the DNS system and reverse DNS lookups have stopped responding.

And as for Ident, that is an absolute pain, and should not be used.
Anyhow - glad it is working again.