Little annoyances in Windows XP

OK, so I have a couple things with Windows XP that I want to go away, if that is at all possible.

First, the start menu. I already switched it to the Windows 98 format, cause I like the look of that better (that is to say, I’m used to it.) But one problem I can’t see mto get rid of. When I go to programs, the list of programs that comes up is small. It only shows the programs that have been used recently. I want it to always show all the programs and folders, so I don’t have to click on that arrow. It annoys me to no end.

Secondly, the network neighborhood icon. Man oh man how this lives to piss me off. I want it to do what it did in Windows 98, and that is show a list of all the comnputers in my workgroup, and then let me go to the entire network, where I see all the workgroups. Instead, it shows an innaccurate list of all the folders on the network. It shows folders tha don’t exists, and folders that did on exist on computers that are no longer on the network. I righ-clik and hit refreash, but that does not help, the same non-existant folders show up. I don;t want to see the folders! And, if I have to resort to seeing them,show the correct ones, and instead of telling me what computer they are on by calling the computer by it’s comment, call it by it’s name. For example, one folder is called
“Downloads on the Jewish Messiah of Computers (CapnAlf)” Why not just say “Downloads on CapnAlf”, since that’s what it is? Stupid, stupid, Win XP.

So, is there any way to allieviate these problems?

First, Right click on start menu, properties, customize the classic start menu, uncheck ‘Use Personalized Menus’.

Second, there’s a window inside the network connections that does what the old network neighborhood window does. Just make a shortcut to that window on the desktop and use it instead.


In general - this is a great site for all kinds of Windows annoyances:

For tweaking XP do do/not do a bunch of things, check out

“When I go to programs, the list of programs that comes up is small.”

Isn’t that active desktop enabled?

That is unchecked.

OK, nevermind my last post. It was unchecked, and it fixed it. But the network thing is still a problem. I see kinda what LordVor is talknig about. When I open Network Neighbourhood, there is a column on the left, and I can click on a link that says ''show all computers in my workgroup." I click it, and voila, it was like what win 98 did, but I can’t seem to get it to stay that way, or to make that the shortcut. I can’t right click on it or anything, only click to go to it if I’m already in the crappy version of net. neighbourhood.

Re: the network thing, if you go into My Network Places, Entire Network, Microsoft Windows Network (phew!) you’ll find the list of workgroups. The best solution would be to back up a step and right-click-drag MS Windows Network to the desktop and create a shortcut. You can then remove My Network Places from the desktop if you’d like, and there you go.

And for the naming of the shortcut folders, well, it really does make sense. The computer name is limited to 11 characters, while the description can be… well, very long. It’s kind of like limiting yourself to 8.3 filenames.