Replacing Network Neighborhood After Little Brother Deleted It

Yesterday I decided to network my computer with my mothers so that I can take advantage of her cable internet link to download some chunky stuff that I’ve been after for a while, and I discovered that my little brother who knows every bloody thing about computers has deleted it, presumably on the basis of I-don’t-know-what-it-does,-therefore-it’s-unnecessary".

How do I get it back? I’ve tried re-installing windows three times and it’s still not there. I can’t find it on the Windows CD itself to copy over manually.

Creative ideas of punishment would also be appreciated.

To speed things up for the computer geeks who will be here in a minute, I will ask, which version of Windows is it?

I always forget to say this bit.

Windows 98 second edition.

Tweak UI (an addition to your control panel) has an option to turn Network Neighborhood on and off.

There are instructions on how to install Tweak UI here if you dont have it already.

Oops, I forgot to give you the link to download it if you need to.

Try this:
In the registry, find:


and delete the value “NoNetHood” (or set it to “0”).

MrWhy, thanks, for your suggestion, unfortunately for some reason it only works with Win98, not 98 second edition.

pmh: I’ve just looked in that part of the registry but there is no “NoNetHood” value. I’m guessing that that’s bad, right?

thank you

It’s not bad. It just means that LittleBro used some other method to hide the NN icon.

Look at the Network Neighborhood properties and make sure “Client for Microsoft Networks” is listed. If not, you can add it from there.

I’ve never had any problem with TweakUI in W98SE. M$ claims it doesn’t work, but it does. (I’m using v1.25 though, not v1.33)

Umm, I have 98SE and it works for me…

At what point does the process fail? Do you see the option but it does nothing? Or do you not see the option all? Or doesn’t Tweak UI install? Or is it something else?

I don’t think I did anything unusual with mine to make it work…



should read:

Look at Control Panel>Network …

NN>Properties would get you to the same place, but if you don’t have a NN icon…

My apologies. I trusted what I read in the instructions, not what happened when I tried it. (I haven’t fiddled around with computers since 3.1 was standard)

Off to do it now… will get back to you.

Oh, and btw “Client for Microsoft Networks” is listed there. off to try tweak.

OK, just tried it. Tweak worked fine, it looks great and I’ll keep on using it, but it didn’t work for this purpose.

What I think the reason for that is that tweak only hides (I think) the icon, whereas my brother clicked on it and hit ‘delete’, wiping it forever from this desktop.

I’ll tell you the rest of the problem in case there’s another answer:
What I’m trying to do it set up what I think is called a “laplink” between the two computers with a parallel cable connection. I’ve decided to do it this way rather than 1)set up a proper network or 2) stick both drives into the same machine becuase for 1)I lack the funds and for 2) I lack the technical know-how. A cable cost about AU$15 and so far I can use the ‘directcc’ application to connect the computers, but I can’t access their drives. I’m sure this has to do with the missing NN. If there’s another way around this please let me know.

Thanks all.

I don’t know how your brother clicked ‘delete’ on it when it isn’t even an option to do- that’s why so many people use Tweak to hide it.

Another possibility, and it’s pretty remote, is to check your system for X System. It’s a utility like Tweak but it’s much more thorough and deep.

Do a find from the start tab and search for both x-system and xqx.

If either of those pop up, then he might have removed it from there. It’s doubtable, but you said he was knowledgeable.

At any rate, if it is, I’ll post how to navigate through there and get the icon back.

Let me know.

Cnote is right; you can’t just “delete” it like other icons. (As if you needed my validation on that point. :))

But I would also like to add that there are a few utilities that can tweak your system like X System. You may have to ask your little brother which one he used. (Where is he anyway? - you should make him fix the problem!)

Or, as a last resort, you could format your hard drive and reinstall windows again. I don’t know how much of a problem this is for you, but you say that you have reinstalled three times, so it might be an option. Annoying though…

Are you really sure it’s gone? It’s fairly easy to change the name and icon, so you may not recognize it. It may also be moved to screen position not displayed at your current resolution.
Does it appear in the desktop toolbar? (right-click the taskbar and select Toolbars>Desktop)
Does it appear in Windows Explorer?
I can’t think of another way to hide it, so if/when you find out how it was done, please let us know.

In the meantime, I think I can help you with DCC.

DCC is (or has been for me) THE most difficult way to connect two machines.

But it seems you’ve got the hard part accomplished already. The DCC wizard says they are connected right?

Sharing must be enabled. Open “Network” in Control Panel, click the “File and Print Sharing” button, and check the appropriate box. You will need to restart.
Then, in “My Computer”, right-click the drive you want to share, select “Properties”, and set the appropriate options on the “Sharing” tab.
You will still need NN to access the other computer, so if it doesn’t appear in Windows Explorer, we may be right back where we started.

good luck

One more thought.
In Control Panel>Network, make sure the “Primary Network Logon” is set to “Client for Microsoft Networks”.

Also, if you have separate user profiles in use on your system, check for (and remove) the “NoNetHood” value under


FWIW, TweakUI, PolEdit, and X-Setup use these HKCU and\or HKU.D key values to hide the NN icon, so if one of these keys is not present, I doubt such a tweaking program was used to hide NN.

Another thought from me too-

I ran across an article that mentioned the icon may be missing because it’s now a part of the ‘My Computer’ icon. It’s there, but it’s not a seperate icon anymore. But, it was directed at Win ME users.

I know you said 98 SE, but I thought I’d add that just in case.

Ya never know!

Guys, thank you for all your wonderful suggestions. unfortunately they haven’t done the trick. I’ve decided to take it back to the shop and see what they can do. It’ll probably be something incredibly simple that I’ll have to fork out $50 for, but I need this stuff.

Re my brother. He’s currently in Bali at the moment, so that’s no good (I’m in Sydney). Also, when I said he knew ‘every-bloody-thing’ I meant that he knows very little but thinks it’s a lot. I.e., he knows enough to screw it up but not enough to fix it up. That’s usually left to me.

I’ll post again when I get the answer to let you know what was wrong.

Thanks again,


Ctrol panel > network > add client for MS networks