MP3 help... please!

<Disclaimer: I know next to nothing about PC’s>

I just got an MP3 player I bought on the intraweb. Of course I can’t make it work.
It’s a Sansa m230 MP3 player. When I plug it into the usb port the computer (a pop-up) says it recognizes it but I can’t find the icon. Grrrr…

Can someone please me help with this. [sub]I’ll bring pie[/sub]

I have a Sansa e130. The computer sees it as a regular usb mass storage device. It does not see it as an mp3 player. When I plug it in I get a new drive letter under My Computer and can copy to and from it like a hard drive of floppy disk. Does that help?

You can print the e200 (Generic e series) from the Sandisk site. I bought a reconditioned e250 with only the connecting cable and buds and it stopped working. I’ll check back later to see if you have any success.

The “new drive” is not shown under My Computer. A pop up from the menu bar does say usb mass storage devise recognized (or something like that), however.

Can you drag songs to this pop up menu?


What OS? Sounds like it is finding the hardware, but is not successful when installing it. After you plug it in, check devise manager to see if it’s there as a new USB devise or something. If it’s a flash memory devise, there is a small possibility it’s defective. Maybe try it on another computer to see what’s up. Let us know.

Yeah, I’ve never had a problem finding my mp3 player (same model I think - sansa m230) in ‘my computer’ under windows XP. Alternatively, you could try using windows media player or realplayer or some other music software to transfer songs.

Good luck!

My GF and I bought 2 of these and I’ve tried them both - nada. Her computer is a Dell running XP. When plugged in, the MP3 reads “USB Connected” and “MIP”.

I have two of the Sansa m260’s (the same as yours, only the 4GB model). Man, if they had a bookmark feature, they’d be perfect for me. Anyway, with the Sansa m-series, you have to set it to MSC mode to see it as a drive on the computer. Hit the power button to bring up the menu, then go to “USB” and choose “MSC” instead of “Auto Detect.” Makes it a lot handier for copying stuff over; otherwise the stupid thing is in “Media” mode or some such nonsense and you have to use specialized software like Windows Media Player or iTunes or something along those lines.

Do you have a lot of other drives on your computer? Your player might be trying to map as a drive that already exists. The way to change that is to right click on “My Computer” and go to “Manage”. When “Computer Management” comes up, click on “Disk Management” and see if your player shows up. It would show as a drive without a letter. From there you should be able to reassign an unused drive letter to it and it will then show up as a usable drive on your system.

This is assuming you are running Windows XP, of course.

Couldn’t get my computer to acknowledge the USB object either. I suspect we need an upgrade from the Sandisk cite and or the installation CD. Having neither, I used a thumb drive in the USB port and loaded the micro SD card. Put the card in the player and all is fine, except now I have to delete the crap alrady on the player. If you are still having trouble e-mail me S(See my profile)

Hi all, thanks for your advise. Sorry I haven’t had as much time at the computer this week. Anyway…

chorpler, your suggestions seemed promising. I hit the power button brought up the menu but it still says, “MTP”. I could not get it to scroll through the menu selections. Checking the enclosed instructions I notice Location Of Controls # “8. Volume control/menu navigation”. Alas, no combination allowed to actually happen. If you have a more step-by-step suggestion I would love to hear it.

Dragwyr - I clicked on “Disk Management” but no player shows up.

Old Goat - I’ll try the Sandick site.

How do you ‘go to USB’?

Just so it’s clear, I’m talking about the menu on the Sansa m230 itself, not on the computer you’re connecting it to.

When you tap the power button to bring up the menu (by “tap” I mean press it briefly – don’t hold it or the player will shut off), it brings up a menu with the following entries:

Play Music
FM Radio

That’s the default, anyway. If you have turned “Advanced” on under the Settings menu, you will see the following menu instead:

Play Music
FM Radio

But we’ll assume the menu isn’t on “Advanced” mode for now. So you should see the top version.

Arrow down three times (by pressing the “Repeat/AB” button on the right front of the player, next to the screen – those four buttons can be used as up, down, left, and right, and the middle button can be used like an “Enter” key) and hit enter on “Settings.”

This will bring up the Settings menu, which shows (again assuming “Advanced” is turned off):

FM Settings
Reset All

Arrow down 7 times (or arrow up twice, since the menus loop around) to USB and hit enter. This brings up the USB settings menu, which says:

Auto Detect

There’s probably a check mark by “Auto Detect.” Arrow down to “MSC” and hit Enter. This will set the option to MSC, which is what you, and will return you to the settings menu. If you want, go ahead and switch “Advanced” on by arrowing up to that and hitting enter; this is handy because the device will remember where you were in the menu if too much time passes and it goes back to the playback screen.

Anyway, you can either get back to the main menu by pressing left, then get back to the playback screen by pressing left again, or just switch from the menu back to the playback screen by tapping the power button again.

Edited to add: Also, if you hit Menu and then Information, it will display (among other things, like the memory used and the number of songs and audiobooks you’ve got on the player) the current firmware version of your player. Mine says “-2.2.1A,” as in negative two point two point one A in case that negative sign is hard to read. They haven’t had a firmware update in a long time, but if your firmware version is different you might want to check the Sandisk website anyway.

Good luck. Let me know if this fixes your problem, or if there’s some step that you can’t do because your player is different from mine in some way.

Thanks for the help chopler. I still did not get any music to download but I did get menu up and I did get my GF’s computer to recognize the devise so there is hope (I wasn’t tapping the ‘menu’ button quickly enough).

I have to go to the city (SF) for the weekend, but I’ll check back in when I return.

No problem. It should now show up as a regular disk drive on your computer when you plug it in, so you should be able to copy files over to it just like any other disk drive.

And if it works, I like banana cream pie. :cool: