Mysterious messages from Microsoft Word

They tell me to kill my dog.

Sorry. It’s late and I’m frustrated.

I get a lot of Microsoft Word files posted on our secure school site by professors. I wasn’t too surprised when one download suddenly annouced that the file had macros. Apparently, my computer is e’scared of macros. I confidently told the computer to disable the macros, and life went on as usual.

Except now every damned file seems to have macros enabled. Even if I start up Word into a blank document. Macros! WTF?

One more thing: These files don’t seem to cause the same macros scare on other computers. But maybe the security is set differently?


A macro present when you start Word clean and create a brand new document means there are macros in your file. This file is the template that Word uses to create all new documents, and is where you store any custom toolbar buttons, menus, etc. You can edit it to modify how documents are created, if you’d like (for example, I changed mine to use 1" side margins instead of 1.25").

To get rid of unwanted macros, start Word clean and go to the menu and select Tools, Macro, Macros. You will see a list of macros. The “macros in” dropdown box will allow you to select what macro source you want to review. In your case you should just see You can delete the macros you don’t want, which in your case may be all of them.

You can set the security level for macros by selecting Tools, Macros, Security and selecting the appropriate choice.

If you load a Word document with macros, some of those macros could be written to create macros that attach themselves to your file and become sticky. I am not sure how that could have happened to you if you got a warning and chose to disable macros. It is possible to write viruses in macros, which was quite a fad a while back.

The plot thickens.

I restarted my computer just to try to get as fresh a version of Word as possible.
In my Macros window, there are several “macros in” options:, Word Commands, Document 1, and There are scores of macros listed within, mostly in the Word Commands and options. The kicker is that I can’t seem to delete any of them. I can select them, but the delete button remains unclickable. Any ideas?

PDFMaker is part of AdobeAcrobat. You don’t want to touch those.

First of all, don’t delete the macros listed under Word Commands, or you will totally hose Word. (This is probaly why you’re not allowed to.)

Have you checked your security settings as CookingWithGas suggested? That should be your first stop.

After that, if you are sure that you have no macros that you need in, you can try deleting them in the Visual Basic Editor. Tools > Macros > Visual Basic Editor (in Word 2000, anyway). On the left side you should see your Project Viewer, and a listing for Normal with a plus sign next to it. Click that, and then click the plus sign next to Modules. You’ll probably see only the “NewMacros” module. Double-click that and delete whatever shows up in the right pane. Save, and then close the Visual Basic Editor. Reopen Word and see what happens.

You could try looking around in the VB Editor under “Document 1” (with your blank document open) and also under Normal > Microsoft Word Objects > ThisDocument to see if you have any document macros loading on start.

Another option is to close Word, go to your templates folder (location is listed under Tools > Options > File Locations > User Templates), rename to, and reopen Word. This will generate a brand-new Normal template. You will lose any custom settings, but it will enable you to tell if the problem is in Normal. To go back to the old settings, close Word again, go back to the templates folder, delete the new, rename to, and reopen Word. That will put you back the way you were.

I think I got it.

Setting the security to medium, the program finally announced that the macros it was scared of were from PDFMaker. I’ve now enabled them and all seems well. I’ve also put the security back at high. Wonder what made it freak out all of a sudden.

Thanks all!