Need help with HP network printer install in Windows environment

Long story short I am trying to connect this HP P3005dn mid sized office networked printer, which appears to work fine in stand alone test mode to our network. Our environment is mainly a Windows house running mix of Windows 7 and windows 10 with a few Macs. The network is some MS server flavor.

So… I plug it into an Ethernet wall connection in the media center that I think is still active and go about 20 feet away to my desk to try and find it on the network, give it any drivers it wants once recognized and print. I a using a windows 10 machine. The printer install search feature under settings cannot find it. My PC is just a regular connected PC on the network it does not have any special server admin privileges.

It’ s not plug and playing. Shouldn’t it just pop up as available on the network once connected or is that just for simple home networks? Should I check the ethernet wall jack connection by disconnecting and hauling a PC and a cable over to the connection before doing anything else or is there more I can check re the printer install before doing this? Do I need to do more to get it ramped onto the network? Will I have to call the IT contracted service providers with admin privileges (at a cost) to set this thing up?

I’d start by standing at the printer and selecting the menu options on it to print a configuration page. Does it show that the printer has an IP address? Generally, you’d set it to DHCP and let it get an address from your server, but your network may require it to be configured with a static address.

This is what the config page says re settings (jpg pic of page)

Looks like that printer has been manually set with an IP address that is already taken on the network. Switch it to DHCP and reboot the printer.

Thanks much! I will poke around the config menu and see how to do that. I don’t see any option or toggle called “DHCP on/off” but it’s probably called something else.

Thanks we are good to go!

Great!

If you have a server, create a print queue on the server for the printer and have everyone connect to that, rather than the printer directly. And now that the printer has an IP address, make that IP address a reservation on your DHCP server. You don’t want it changing and suddenly no one be able to print.

IT guys kill people for doing that. :dubious:

Is this new printer config going to cause network troubles? (jpg pic of config page attached)

It did not auto recognize in a new printer/device scan done by my PC I had to add it manually as a network printer using the tcp-ip address. Once I used that address it saw and recognized the printer and set it up automatically.

Since it’s now getting an IP address from your DHCP server, it should not ‘cause network troubles’, but you may run into a different problem:

If you ever turn the printer off for an extended* period of time, then when you turn it back on it may get a different IP address from the DHCP server. At that point, the print queue that was created on your PC will no longer work, because it will at that point be pointing to the ‘wrong’ IP address. You can get around this by setting a reservation on the DHCP server (so that it will always give out the specified IP address to that device), or by setting a static IP on the printer (which is what was done originally, but the IP in that case was ‘bad’…probably because it was already in use by another device).

If you understand what I’m saying, then you can make it work; if not, then you’d need to call your ‘IT Guys’.

Or, if you never plan to turn the power off to the printer, you can probably leave it and it will work just fine.

  • ‘extended’ being defined by the lease settings on your DHCP server: which could be as short as a few minutes or as long as a few weeks.

When the computer guys try to set that printer up for other users, expecting a static IP, they will have problems.

If you install from the manufacturer’s software, there is an option to stay connected if an address change occurs.

Why aren’t they taking care of this to begin with? :dubious:

This specific printer have issues at times. For example, it freeze up and give an error if you try to print from ASP.NET webpages (aspx) using Internet Explorer, but it work if using Chrome.

I am an IT guy. It is the fault of the IT guys in this scenario to allow open ports on the network in the first place. Maybe this is how they told him to do it.

Simply telling him to “call your IT guys” isn’t really a solution.

I’m an IT guy too (a sysadmin at this point to be specific, but I use to be a ‘one-stop shop’ in the past.)

This has nothing to do with ‘allowing open ports’; it has to do with a device being placed on the network with a configuration that is not correct for the environment that it’s being placed into. And “calling their IT guys” is exactly what they should be doing…it’s the IT guys’ job to set these things up, and to it in the proper manner. Users setting devices up on their own is what causes these types of problems in the first place, as evidenced by the OP.

To be fair…I can understand why the OP didn’t want to call support to begin with ($$$), and that’s completely understandable. In a perfect world that wouldn’t be an issue, but we haven’t quite reached that point as a society yet.

Yes, it DOES in fact have to do with “allowing open ports” and I can count at least 5 more configuration, security, and operational flaws with his plan as well. He asked for advice on how to get his printer working, and that’s what I gave. His printer is working. He didn’t ask “Should I connect my printer up this way?” He asked HOW to do it, and I told him.

When someone else needs to be connected to that printer, it will be given a static IP, and this user will have to be reconnected. It should have been done corrected properly the first time. He will be without a printer twice instead of once. :slight_smile:

Or they will use the assigned DHCP address to make a reservation and everything will be good :slight_smile:

They won’t know it has gone DHCP.
A static address is advantageous when you have to work on the damn thing. :slight_smile: