New A.I.M. for Mac- issues?

There’s a new A.I.M. for Macintosh users..

Downloaded. Installed supposedly properly. No love- it crashes when I try to sign in, and quits.

Did a Restart. Uninstalled, and did a fresh download and install. Nothing. Anyone else tried this? It says it supports from 10.4.8 upwards, and I use 10.4.11 .

Hmph ! Any one installed it successfully ? How?


Don’t have any answers for you, but there are about a thousand AIM clients for MacOS X that are better than the official one.

The built-in iChat supports AIM, as does Adium, Fire and Proteus.

True. But AFAIK, only AIM and AOL supports the WeeMees.

And they are so very cute. :slight_smile:

It works fine for me, but what I don’t like about it is that the buddy list displays everyone, including even those who are not online. To see who is online I have to scroll through a long list looking for the names with black font instead of gray italics. Is there any way to fix this? I didn’t see any relevant options in the preferences.

Also, I didn’t see an option for having chats automatically logged, which I wish it had.

What OS are you using?


Well. It’s a mystery, and a bit of a drag. I use that IM’ing software above all others and was happy to be offered the upgrade. I just removed, trashed, emptied trash, restarted machine, and did a fresh download and install.

Identical issues.

Check your Crash logs - look for any obvious startup item names mentioned.

Not sure what that means. I know where to look for Startup Menu items on the Mac, but what’s a Crash Log?

The install from yesterday, in my Applications, is called " AIM 17-08-45 ". Huh?? The new install from middle of last night is just called AIM.

There are choices for the Default AIM Client.

  1. AOL Instant Messenger (SM) (4.7) [ That is the old AIM I am using now. 4.7 ]
  2. iChat (3.1.9)
  3. AIM 17-08-45 (1.0 )
  4. None

None of these options allow it to sign on.

This is only a portion of the Problem Report for AIM. I assume this is the Crash Log you refer to?? Anyone understand this language?


Date/Time: 2008-12-19 15:31:06.389 -0500
OS Version: 10.4.11 (Build 8S165)
Report Version: 4

Command: AIM
Path: /Applications/
Parent: WindowServer [66]

Version: 1.0 (46)

PID: 17932
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0 <<00000000>> 0xfffeff20 objc_msgSend_rtp + 32
1 0x907c0dc0 _CFArrayReplaceValues + 372
2 0x92bf4454 -[NSCFArray insertObject:atIndex:] + 224
3 AIM 0x01043840 AccOcPreferencesHook::SpecifierToArray(unsigned short const*) + 196 (icplusplus.c:28)
4 AIM 0x01044178 AccOcPreferencesHook::GetValue(unsigned short const*, tagVARIANT*) + 352 (icplusplus.c:28)
5 AIM 0x01198730 AIMCC::TAccPreferences::GetValue(wchar_t const*, tagVARIANT*) + 380 (icplusplus.c:28)
6 AIM 0x010425e8 -[AccOcPreferences(Ext) typedValue:forKeyPath:] + 300 (icplusplus.c:28)
7 AIM 0x0104269c -[AccOcPreferences(Ext) unsignedValueForKeyPath:] + 40 (icplusplus.c:28)
8 AIM 0x01027cc8 -[AccOcExecutor(PrivateExt) actions] + 44 (icplusplus.c:28)
9 AIM 0x01027b0c -[AccOcExecutor executeActions] + 36 (icplusplus.c:28)
10 AIM 0x0105501c -[AccOcSession(Ext) signOffSync:] + 56 (icplusplus.c:28)
11 0x000e1ea8 0x1000 + 921256
12 0x000e3db0 0x1000 + 929200
13 0x0005dfb0 0x1000 + 380848
14 0x0005de28 0x1000 + 380456
15 0x001fe188 0x1000 + 2085256
16 0x938418b4 -[NSApplication sendAction:to:from:] + 108
17 0x00099d0c 0x1000 + 625932
18 0x938417e8 -[NSControl sendAction:to:] + 96
19 0x938416c8 -[NSCell _sendActionFrom:] + 156
20 0x9385b664 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 1020
21 0x9385b24c -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 564
22 0x9385ac70 -[NSControl mouseDown:] + 536
23 0x937fc4e0 -[NSWindow sendEvent:] + 4616
24 0x937a5524 -[NSApplication sendEvent:] + 4172
25 0x9379c960 -[NSApplication run] + 508
26 0x9388d458 NSApplicationMain + 452
27 0x000042e8 0x1000 + 13032
28 0x000031cc 0x1000 + 8652
29 0x00002ed0 0x1000 + 7888

Sorry, I didn’t have time to get into this in detail this morning.
Launch Applications->Utilities->Console
File->Open Quickly->~/Library/Logs->AOL crash log (or AIM, or whatever).

The log will be filled with all kinds of gibberish. But, even non-programmer types can often spot suspicious key words. You can also copy the crash log and PM me, and I’ll see if I can spot anything.

ETA - I see you found it.
Have you dumped your old preferences? I see indications it might be a preference problem.

Talk bout yer simulposts… :smiley:

Should I PM you the whole log?

ETA: Will dump Preferences, re-start machine.

You can send it to me, but see what dumping the prefs does first.

Quit any running mail App. Toss the Plist. Reinstall while mail is not running. Launch, Quit, Start mail, launch again.

The Preferences Folder under Library under House…is…HUGE. Tons of things in there. Am I to Trash the entire Preferences folder?

If so, I’ll do it. Are my Preferences re-set as I use other Apps?

Will do what Morbo said, once Preferences issue is cleared up.

Determined to make it work !

If I were going to guess, I’d say to just trash:

Nope. I did toss the Plists. One was plist, one was plist for desktop. Followed all steps above.

Plist gone, because fresh install did not already “know” my member names. Tried to log in. It’s still saying “connecting”, which it will do until I hit Cancel. Software closes up again too.

Other ideas? What did I miss?

ETA- did what UncleRojeliosaid in terms of chosing the Plist.

And, still trying each Default AIM Client ( What does this mean, anyway? ).

None work.

And, oddly, the member name I am using doesn’t “stick” when I try to log in. It is as though no new Plist has been created, even though I’ve launched the new AIM software. Shouldn’t a Plist be created when I launch the software?

This is…perhaps…the 5th download at this point. All have been banished to trash and deleted.

Hmmm…you’ve stumped the band at this point. I’d suggest searching for existing posts / posting this on the maxfixit forums.

I registered and posted into the proper forum there. Thanks.

Really quite vexing !!