'Nuther 'puter/printer question

Pentium II 'puter, HP LaserJet4 printer. I printed something last night, shut down normally, came in today to print off reams of stuff and got an error message, saying to check if my printer was turned on (it is) and ‘online’.

well, went to ‘start’, ‘printer’ and sure enough, it says that it’s ‘offline’. Have checked to see that all plugs are plugged in, did the ‘help’ topics search for printer etc, looked at ‘options’ etc., couldnt’ find anything that would tell me how to get said printer ‘online’.

Tried re-booting, too. nada.

Well, that’s it. I’ve exhausted my personal repetroire of ‘this might work’.

So, what now?
(as an aside - this computer/printer was set up by a funding source, they’re wanting the equipment back, hence needing to print out mega amounts of stuff, and they hooked everything up - therefore, I do not have the discs they used to set up the printer, nor would they allow me to access them).

Check the printer. There’s a button somewhere that takes it offline.

Forgot to mention.

On this printer, the ‘buttons’ available are:

  1. a gizmo to set the printed page to shoot out of one of two orifi

  2. another gizmo (aren’t you dazzled by my command of technical jargon?) that will pop open the cover to allow you to put in a new cartridge

  3. another one to open where you put paper in

  4. what I call the “reset” button on top (which I’ve hit now, counting, one, two, three, four times, allowing me to have now 4 copies of the ‘test’ sheet for the printer.)

Appreciate the suggestion, though.

So. To summerize - the printer itself seems to work. The computer will accept the command to print and seems to acknowledge that there is a printer attached, but it doesn’t seem to think the printer is turned on. Yes, again, I have checked the cable connections. all seem snug.

wring, try and recycle power to the printer. I have this problem sometimes with my windows machines and locally attached printers. I’m no expert with these things but that almost always seems to clear the problem.

A laserjet 4 what? I’ve got a full sized standard LJ 4 in my office and it does not sound like your unit. It sounds like you are describing a 4P or a 4L which are very different beasts.


1: Borrow a printer cable from another unit to test it with.

2: If it still is not recognized after trying #1 make sure it is defined as the default printer or is specifically identified as the printer you are printing to.

3: If it is a 4L the unit never truly powers down while plugged in. Remove the printer power plug from the wall and let it sit for 10 minutes then plug it back in.

astro 4-L (according to all of the test sheets)

(It is defined as the default printer, I’d checked that) Will try your other suggestions in the AM (hungry teen just arrived) thanks much

breaknrun would be happy to try yours as well, but I am not sure what you want me to do. I’m not a tech, (see OP) but can follow directions (and doesn’t run with scissors, either) :slight_smile:

Thanks mucho!

I got a LaserJet4l. You might try another printer cable first.

wring, if there is a power switch on the printer, turn it off, wait a few seconds and turn it back on. If you can’t find a power switch, just pull the plug to the printer. You can also just try unplugging and reconnecting the printer cable, even though they seem snug. If all that fails, can you connect the printer to another computer to test?

Lj4l don’t have a power switch, they are autosensing, in other words, they go on when you need them. They also go on first few minutes you plug them in. I like this whole idea.


Please excuse if I insult your integlligence.

On the printer, 2 lights should be on, power and ready.
If ready light is not on press the ready key.
If it, or the form-feed light is blinking, press the form feed key.

(I assume Windows 95/98)
On the computer,
Click on Start (at bottom left of screen)
double-click on the Laserjet

Are there a bunch of things waiting to be printed?
If so, click on File/Purge All Documents (may say Purge Print Jobs).

Back to Printers window,
Right click on the same printer
Choose Properties
Click on Print Test Page button.
Back to Printers window
Double-click on the same printer.
See your test page queued to print?
Is the light on the printer blinking?
Still no good?

On the Printers window,
right-click on the Laserjet
choose the Details tab
Do the Port and Driver look “reasonable”?

Click on the Spool Settings button
Try changing the Spool data format to Raw
Try printing the Test Page again.
No luck?
Try Restore Defaults here.

Let us know how it goes. There are more (fun) things to try.

really appreciate the effort here.

Unplugged everything last night. didn’t help.

Cannot change printer cables - it’s hooked up directly through the printer (a cable comes out of the back -don’tyoudare open me end- and then hooks up to the computer). cannot switch it to another computer (folks who actually own the stuff kept the manuels and the floppys needed to install)

Nut no problem I appreciate your willingness to help.

no bunch of print jobs waiting.

With this printer, there is an ‘on’ light which is on as long as the printer is on. The ‘online’ (I suspect) light goes on and flickers when a print job is in que line.

Did the thing with ‘print test page’, it was listed as a job, but the same things then happened (ie nothing was printed, and got the same error message as before).

Port and driver look reasonable (LPT one and the correct name of the printer for the driver). Did the spool changes - nada. Did the restore default. nada.

curses. broiled again!

The 4L printer is not wired directly. This is simply a rear hatch cover on the back of the 4L and is meant to be easily and simply removed if you desire. There are two places you press on the rear cover to release it and underneath there is a standard centronics printer connector. Take the cover off and check that the cable is seated correctly or try another cable.

Ah Ha those clever bastids. found the cover but am on my way out for the night, so will have to try again manyana.

thanks so much for workin’ with me on this (‘the trainable non tech person’)

Its really pretty much the same as my LJ4L. I have the manual so lets see how a cable does for you.

Oh wriiiiiing:

It’s ma~nana (plus a day). Wakey wakey.

Let’s delete your printer and reinstall it! OK? OK?

Sorry, I was at a meeting. Tried the new cable, nada. would gladly uninstall printer and re-install, ceptin’ I don’t have the attending stuff to do it. For example, I once tried to put that printer onto a different computer, and it asks for discs to run an ‘install’ program. I don’t have the discs.

So. What I’m gonna do is give up - I’m supposed to give the stuff back on Monday anyhow, will defrag (or whatever the hell it’s called) this computer and set up a different (slower, sigh) one with a new printer (which I purchased, so I have the manuals etc.).

I thank you so very much for your willingness to help me. You have no idea how much I appreciate it. (the ‘support tech’ that’s supposed to be in charge, and to whom I’ll be delivering these items next week- well, let’s say that when I told him that the system rejected my password in order to check my email on HIS system, yet A. the computer worked, B. the modem worked. C. I was able to check my hotmail account, so the “outlook” program was working, and D. was able to access the web as well - he told me “your computer’s broken and I don’t have the time to fix it”.)

So, thank you from the bottom of my heart. Really. If we meet up at a dopefest or whatever, the next beer’s on me (assuming you’re of age :smiley: )

Another answer that may insult your intelligence. Is your printer “paused”? IE: in the control-panel->printers if you right click the printer is there a checkmark next to “pause printing”?

Sometimes the silliest things happen.

You know, it’s funny - all of you have said ‘don’t be insulted, but…’ and all I’ve felt is grateful that you’re willing to help.

But, in answer, nope c_goat, it wasn’t ‘paused’ . During this time, I got intimately (sort of) acquainted with the whole printer options stuff. And, yes, I’d seen a part where you could pause the printer, but it wasn’t.

But thanks anyhow.

I just checked on this here win98se machine, and the HP 4L driver is shipped with the OS. so you don’t need the disks/CD’s to reinstall the printer.

Also, if this computer has internet access, you can d/l the drivers from http://www.hp.com/cposupport/swindexes/lj4l_swen.html?Submit.x=5&Submit.y=4

Eek, gotta go.

good luck.

Thanks will try that (the things I go through). Deleted printer file, went to add it back, it insisted I needed a disc. So, am about to do the download as directed, but have to shut everything else down. (Damn, it never lets me have any fun). will let you know.

Have I said thank you enough??

I don’t think so. :smiley:

(By the way, to prove I’m not a complete ignoramous: I had an ‘outlook explorer’ on this one that would open and retrieve mail from both my work account and hotmail. I was able to delete the ‘hotmail account’ off of it, without having to come back here, email pals, or even hit the ‘help’ button!!! Maybe I’ll buy myself a beer?)