Oblivion Help: Mercator Hosidus Stood Me Up

I’m planning on getting Skyrim for my birthday, and in the meantime, I’m re-playing Oblivion. Right now I’m doing the Ulterior Motives quest for the Mages’ Guild. I went to Skingrad and was told to come back the next day. I went to the chapel and quick waited 24 hours, went back to the castle and was told by Mercator Hosidus that the count would meet me at such-and-such place after 2 a.m.

So like a good little mage, I went to where the quest marker indicated and waited. And waited. Nobody came. No count, certainly no Mercator. I went to the castle the next day, and there was Mercator, only now he was dressed in his Necromancer’s robes. He said again, “Wait for the count after 2 a.m., stupid.” This wasn’t right.

So I re-loaded my last saved game just before this quest and tried again, this time waiting somewhere else, then going to the quest marker at around 10 p.m. Still no Mercator. I re-re-loaded the game, and waited somewhere else (but near enough to the quest marker) until 2 a.m., then went to the quest marker. Still nothing. I’ve tried everything I can think of, and every online search only mentions a glitch concerning the first waiting period, not the 2 a.m. rendezvous.

What am I doing wrong? This did not happen during my first play-through. Is there any way to fix this? Is it my breath? I’m getting very frustrated.

Go here and scroll down to “bugs” and try the first fix.

EDIT: And if you’ve been told this fix before, download the patch. You are playing on PC right? If not, sucks for you.

Sucks, indeed. I’m playing PS3 GOTY Edition. :frowning: Thanks anyway.

When people tell you to get the PC version of Skyrim, this is why.

Get the PC version of Skyrim.

Lesson learned.

The Skyrim HD pack makes the game. Ah those poor console kids.

For the record, I feel like my other post came off a little harsher than I intended. I do feel bad that you’re stuck in this situation and I wish I could help you more, so I apologize.

No problem, I didn’t take it that way. Still frustrated as hell, though. Maybe I’ll try doing another quest and coming back to it.

even the PC version has problems with trigger events, there console commands can fix some of it. If you can access console commands it might do the trick.

I FINALLY got it to work! I re-loaded the last save before the quest, and go to the point where Mercator told me to wait in the pasture at 2 a.m. Instead, I went to Anvil, did the Athletics training quest, then came back. Sure enough, there he was at 2 a.m.

Thanks all, and I definitely learned my lesson. Skyrim will be bought for PC.