occasionally unresponsive (computer) mouse

I have a logitech mx 500 usb, wired, optical mouse.

Last night, using windows 2000, the mouse started to stop functioning randomly. I would be using it normally and suddenly the cursor would stop and it would become unresponsive.

But if I pulled the USB plug and plugged it back it, it would resume working for 5-10 seconds again, before going dead again. The LED was always on, so the mouse wasn’t losing power.

Strangely when I plugged the mouse into another USB port, windows wanted me to install a new driver for it. Not sure if that’s related.

Anyway, I booted into windows XP to see if it was an OS issue - it still stops working randomly, but in XP after a second of inactivity, it starts working again. My guess is that XP has some function that detects an unresponsive mouse and… jump starts it, or whatever it does.

Currently the mouse has been working normally for 10 or 15 minutes, but it’ll probably stop working randomly again. Any ideas?

Strip out and reinstall the drivers.

Are there any other lags when the mouse stops?

Installing the drivers again is quite normal behaviour when you plug something into a different USB port. You end up with a device manager entry for each possible configuration.

It may be that the mouse is on the way out - they don’t last forever - but uninstalling the device manager entries and starting over might help.

The best way to do this is by the cure-all method I described in post #8 of this thread - the Windows Device Manager won’t normally show you entries for devices it thinks are not present, but it could be one of these entries that’s messing things up.

When you get into the device manager view showing the nonpresent devices, uninstall all the greyed-out versions of ‘mouse’ or ‘human interface device’, or whatever it’s called, then uninstall the non-greyed out one last - your mouse will stop functioning at this point and you’ll be reliant upon keyboard control to shut the device manager window and restart the machine (<Alt>+<F4> is pretty much all you need).
When Windows restarts, it will detect the mouse and install a fresh device manager entry for it.

Nope, it’s strictly the mouse cursor that stops functioning, everything else is normal.

I’m trying a different set of USB ports and so far so good, but it could start up at any time.

I’ve had a similar thing happen, and it turned out to be completely unrelated to any problem with the mouse or its drivers. The problem was that another process was periodically hogging the CPU for a second or two, making other processes, including the one that moves the mouse cursor around the screen, grind to a halt.

I ran Task Manager and watched the Performance and Process tabs for a few minutes to establish which processes were spiking like that. Then I Googled to find out what those processes were responsible for. That, and a bit of trial and error identified the culprit as the wireless adapter’s driver or associated software. Temporarily disabling the wireless adapter fixed the problem.

But it could be something different in your case. Depends on the particular hardware and software in your computer.

slight hijack, but I had a similar problem with a wireless adapter hogging resources. I was burning some DVDs and was puzzled why it took 3 hours each, and he system ground to a halt while doing so. Disabling the wireless adapter fixed the problem, and the DVD burns returned to their normal rates.

Think I solved it. Plugging it into the rear USB ports seems to fix the issue, so it’s a loose internal USB connector or the front ports are bad - or maybe the controller is bad if it’s a seperate controller.


Or maybe not. Rebooted into Win2k, and the mouse died within a minute, even in the same USB port that had just worked successfully for hours.

Tried what Mangetout said, and so far so good, but who knows…

Yep, and bizarre.
Sequence of events:

Starts malfunctioning, in windows 2000.

Reboot to windows xp, also malfunctioning.

Switch to back USB ports. Works perfectly for ~6 hours.

Reboot into windows 2000. Malfunctioning. Tried deleting old hardware profiles. Also tried installing the logitech, rather than generic, drivers. Neither worked.

Reboot into win XP, malfunctioning.

So… if it’s a software issue, it’s unlikely that both OSes would have the same problem.

If it’s a hardware issue, why would it suddenly work for 6 hours, and then stop working upon a reboot?


The next step I guess would be to get another mouse to see if it worked. But I don’t have one handy. And I don’t want to buy another $50 mouse to find out it was the usb controller, and I don’t want to buy a $10-15 crappy mouse just to confirm the problem… hmm… but I guess I may have to, unless anyone else has any idea.

You say an optical mouse … what surface are you mousing on? Do you ever find the mouse cursor jumps to some random part of the screen? If so it’s simply losing track of its true movement and position. Try using a plain white sheet of paper as your mouse pad, as an experiment.

That aside, I think Usram has the best candidate for the problem so far.

No, it’s not a tracking issue because the mouse will be dead, regardless of surface, until it’s unplugged and plugged back in (in 2k that is, XP appears to auto-restart it somehow) - it’ll also work again if it’s disabled and then re-enabled within the device manager. Something is definitely happens which requires some restart of the mouse.

It’s not a cpu saturation issue because everything works fine during the period where the mouse won’t work.

It sounds to me like a duff mouse. The pattern of intermittent failure is unusual for a device like this - more often, they exhibit a persistent fault or just stop working altogether, but for it to fail on both OSes takes software out of the equation, to my mind.

I suppose it could be a dicky USB controller.

Is there any way you can borrow another USB mouse to try out for a day or two?

Stupid question: You have checked there isn’t just some little bit of fluff lodged in the sensor hole on the bottom of the mouse…?

I think I figured it out.

I felt all along the mouse cable and there was a point where it felt hard, as if the plastic had lost its elasticity, and was bent somewhat and the insulator was a little frayed.

So I stripped that area and found that the foil shielding and strands of copper wire were fraying and somewhat seperated.

At first I thought the strands of copper wire being mostly seperated was causing the problem… that they needed to be together for it to function, but they occasionally were coming apart as I moved the mouse, leading to occasional failure.

But then I seperated the copper strands completely, and in response the mouse seemed to work fine. So what’s the purpose of that copper wire inside the electromagic shield foil sheath? Additonal shielding?

Anyway, I also noticed that the green data wire had a slight cut in it. My best guess at this point was that mouse movement lead to a copper strand occasionally making contact with the green wire, somehow causing problems. I don’t know much about electrical stuff so it’s just a guess, but after bunching up the copper, seperating it, and taping the whole thing up, I haven’t had a problem.