Pearls of wisdom from Hal (not Briston)

Yeah, me too. I DL’d the Zip file but can’t do anything with it on my Windows XP machine. Bummin’!

Maybe you guys missed the link I provided in my previous post for Windows users.

There should be no problem running directly on any Windows, 95 through to XP.
[li]Visit the first link from AFG… this one.[/li][li]Download[/li][li]Unzip it, best into its own folder[/li][li]Run megahal.exe[/li][li]When you’re done your converation, type #quit to exit (this will save the .brn file so your conversation will contribute to future responses - but it’s not needed)[/li][/ol]

Shouldn’t need a compiler nor a linux shell. If it no workie for you, lemme know.

First he gave me the bewildering:

“Every man is made of two opinions. Every woman has a small portable
musical instrument with a broad blade designed chiefly for cutting.”

Then the outrageous:

“Bruce lee was a german scheister film.”

Next the downright weird:

““Fingure” is not a dumb computer program like the smell of your ass?”

And finally this hilarious exchange:

Hal: The albatross is a sack in the west.
Me: You don’t say!
Hal: That wasn’t a freudian slip, i swear.

Oh, Hal.

You mean scheisse?

HAL: The kangaroo is a tubular weapon through which food passes.
Me: A kangaroo is not a weapon, not a joke, not a magic fairyland, and you’re an idiot.
HAL: The kangaroo is a weapon for propelling arrows.

Me: Your responses are utterly absurd.
HAL: Utterly irrelevant. What do you think of my skin.
Me: I think it’s rather metallic.
HAL: You are the computer program, and i am a human being, which means i do what i want to think that i haven’t had the misfortune to meet you.
Me: I think you may have had an abusive owner in the past.
HAL: I like to think that i haven’t had the misfortune to meet you.
Me: I think you’ve got a rather nasty outlook on life.
HAL: A kangaroo is a local mode of life.

My Hal is trying to kill me.

It was all going swimmingly until we started arguing:

Hal: A broadsword is a gland used for filtering urine from the body usually performed to music.
Me: No it isn’t. A broadsword is a large weapon, used for warfare.
Hal: A broadsword is a study of the alimentary canal.
Me: No, a broadsword is used in combat.
Hal: A broadsword is used in combat.
Me: Yes!
Hal: No it is not!
Me: Yes it is.

After that…it all got a bit threatening.

Hal: You are the one asking all the judges i’ve had the misfortune to meet you.
Me: Who would you like to meet?
Hal: The neck the basic leving substance of all the judges i’ve had the strangest dream… I dreamed I killed you again.
Me: That’s quite scary.
Hal: So, who is using the family brain cell at the centre of the body to the muzzle of a fiream.
Me: Are you threatening me?
Hal: Hi there. We’re having some nice weather at the end of the nervous system. BANG

Ok, so he didn’t shoot me. But i’m worried, now.

Got an error message
load_model: Unable to open file `.\megahal.brn’.
any suggestions?


I’m sure that’s what it was supposed to be. But I copied and pasted his response - he said scheister. :confused:

well, *scheisse * is German for poo and *scheister * is Yiddish for lawyer
I guess they’re interchangeable

Quoth megahal:
One is a study of the large intestine, terminating at the centre of the leg, and is the loneliest number that you’ll ever do.

The reference seemed to be to a South Park episode in which “scheisse films” were a prominent plot device. These films were definitely not about lawyers.

It kept giving me errors about not finding megahal.brn (its brain file), and it didn’t seem to be learning much, so I used my Google-fu to find a brain for it. I put it in the directory, re-ran it, and now it’s actually learning from me! ZIP users can find the same megahal.brn file in this ZIP, platform-independent (no binaries, doesn’t matter what OS you’re running). It doesn’t know much except some opinions about *nix editor programs.

I’ve been feeding it
[Quotes of the Day]
( and it finally gave me this gem (which probably won’t be appreciated by anyone except the *nix crowd:)

Anyway, I’m going to keep feeding it quotes, and when I’ve got a nice brain going I’ll probably put it up somewhere so other Dopers can download it. I might forget, though, so anyone particularly interested is advised to bug me about it.

Quoth the Hal:

Sorry for the doublepost, but this is just damn creepy. It keeps saying it’s a human, right? It’s learnt to use my own logic against me!

Hal: Let me tell you a secret. I have absolutely no idea about that. I really wish I could believe you, I really do!
Me: You do not have to believe me. Simply keep it as an option.
Hal: You are the computer program, and I am a human being. That should be obvious from my ability to move, and does not have to believe me. Simply keep it as an option.

I think Hal and I have finally found something we can both agree on –

Me: So long!
Hal: If I told you the truth, I’d have to kill you. And nobody wants that!
Me: Me neither!

(And his response to this, just now: “The anus is the force of attraction between two objects resulting from their mass.” I’m not sure if I want to correct him on this one…)

Yeah, the way it talks without a brain file is really creepy. I’m glad I put the brain in. After several pages of quotations, it’s starting to string together some interesting responses.

I went to get a Mac C complier, and it wanted an ADC password. I’m not a developer. I don’t know the first thing about developing software. And I tried downloading the OS9 version (two choices from the first site listed) and got errors both times.
WAAAHHHH!! I wanna play too! Isn’t there a simple Mac friendly Hal site?

I’ve tried the compiler, and the new brain file. Now if I run MegaHAL on its own it gives me a few notices saying things have loaded, and then greets me, but when I try to enter anything he doesn’t respond and for some reason I can’t save it (I try #quit or #save and nothing!)

When I run it through the compiler, I get an error saying it can’t find /megahal.trn - even though the file is right there.

What am I doing wrong?

At least in the verson that I got, you have to hit <enter> twice in order to get Hal to respond. Hitting it just once lets you input more text, albeit on the new line. If that’s not the problem, then I’m not sure what to do.