Problem with posting images in the "Caption This" thread

Lately, when it’s my turn to post an image in the “Caption This” thread, I get the “Sorry, you can’t embed media images in a post” rejection. It wasn’t a problem foe me before, but it’s been going on for the past month or so. I’ve tried copying the image and pasting, dragging the image from one browser window to the other, copying and pasting the image address, etc. I managed to do a workaround by posting the image in my Google Drive and linking it, but Google doesn’t permit a full image post. It puts a clickable thumbnail in the post instead.

I did some research, and the only reason I can find is that I have to be on some kind of “good user level” to be able to post images. I also couldn’t quote a post. It’s only happening in this thread and no others. Is there some checkbox that needs to be clicked?

Here’s a prior thread on this topic posted in the correct forum.

There was never a definitive answer, but I’ve linked to the first post that developed a reasonable theory of what’s probably the problem for most users when it happens. The punchline being confusion between trying to paste an image into your post (that will fail) versus trying to paste the url of an image into your post (that will / should succeed).

I always paste first in the address bar of my browser, then copy what I just pasted, and paste a second time in a post. That guarantees a link and not an image being pasted.

I right-click on the image and select “Open image in new tab”, then copy-and-paste the URL from the new tab.

Not an option unfortunately in my mobile browser.

I’m sure that would work on my PC though. But then again, in Edge I can usually just do “copy image link”.

I just tried this for an image I uploaded to Imgur. It did work, but the top section of the image has a dark band across it that says “[Album]”. It’s something like 15% of the photo area. Is there a way to avoid that? Perhaps it’s an imgur problem not a Dope problem?

You posted an album link, not a photo link.

Here’s what you posted:

I tapped on it and followed the link to the album, then (on my phone) tapped-and-held on the photo in the album, copied the link, and pasted in a new tab which gave me this:

Again, you need the picture’s address, not the address of the page the picture is on.

ETA: For some reason neither is rendering on this page for me, but that could be my browser or connection at fault.

Let’s see what this does:

Aha, there we go. That’s a direct link to the jpeg. You’ll actually see that embedded in your post in the DeSantis thread.

I think Imgur is intentionally obfuscating the photo link to make it difficult to do what you want to do. Notice the photo has no attribution to Imgur appearing in it, and they probably don’t like that.

Thanks Atamasama, let me see if I’m doing it right now:

I guess not. But your last post was what I wanted to accomplish.

I think the problem is that Discourse can’t parse .webp images. I’m not sure why Imgur is giving you a webp image. It normally gives JPEGs or PNGs for me.

In fact, if I use the same file name (jOwlR6t) but add .jpeg to the end, the image works: becomes