Rime Room Escape Game... best ending hints?

Hey, I recently downloaded and played the Rime Room Escape game on iOS, completed the game but it said “Normal Ending” and said I was out of the room but still trapped in the book or something like that. I have a padlock and latch that seems to have no use, I’ve tried using it to interact with everything, tried combining them with items I have, etc, to no avail. Even tried using the book on the furnace to burn it, nothing happens. Anyone know what I’m missing to get the best ending?

I’m a tad further that the point you’re stuck at but not all the way out.
The latch can be used. Examine the back of the elevator shaft again.

If you’re talking about the little hole on the side that you use to crank open the dumbwaiter, I’ve already used the crank item to do that, and i can’t remove it to try the latch in the same hole. Oh, well.

The lock that on the main door can be picked up off the floor. That lock has a removable latch that can be used as a tool. Use it to open the steel plate that is in the opening next to the crank.

Hmmmm… Okay, did that, unscrewed the plate, got the part of the photo, put it in the book, get a message that I escaped the confines of the book but something isn’t right because part of the picture is missing… can’t do anything with the lid (?) that was revealed by removing the plate, thought maybe I could somehow use the chain and hook it up to the elevator to lift by the handle, but no… I’m sure I’m missing something obvious here, but I think I’ve picked up everything that can be picked up and tried to interact with everything with every item I have…

When you’re upstairs looking into the back of elevator shaft there’s some stuff you can’t reach, so of course you have to figure out how to reach that.
Once you have a plan on how to do that you’ll find you can’t position yourself where you need to be without being trapped. So you’ll need to transport out and into the room via the book.

Notice too the box on the front of the elevator shaft, about midway down.

Ah, got it! I guess I hadn’t realized that looking at the incomplete photo in the book works as a teleporter. Got the True End finally, thanks for your help, guys!!