Roku Device Connects To My Network, But Not The Internet

I just brought home a new wireless router from my ISP. All of my devices have successfully connected to my network, and thus to the internet. Except my Roku- I run the connection test, and it connects to my network, but not the internet. I’ve restarted the Roku device and the router multiple times, to no avail.

Any fixes? Roku’s help page is not helpful.

Try forcing the Roku DNS to or Are you getting a valid IP (not starting with 169.x.x.x) and gateway?

My Roku had to be on the main network (not the guest network) in order to work. Is yours on the main network?

Which ISP? You might have to change the wifi security mode to something the Roku supports.

It’s working now. Thanks!

What did you do to fix it? Or did it just fix itself?


I had a similar problem with my Roku earlier this week. Connecting to my home network, both wired and wireless, and in both cases it would connect to the network, but not the internet. I checked both the wireless and wired connection with a laptop, and I could access internet both ways. Reset the Roku. No change. Reset the Roku network connection settings. No change. Reset the router. No change. Reset the cable modem. No change.

Turned on my phone as a hotspot, and it worked. The next day, I connected to my home network again and it worked, and it has been fine since then.

In my case, I’m going to say it fixed itself.

Edit: Xfinity, btw.

Seems to have fixed itself. Got mad and played Xbox instead of watching TV, then went to bed. Woke up the next morning, worked just fine.


If you have a recent-vintage networked XBox, you don’t even need a Roku. You can just download apps like NetFlix, Hulu, etc and run them on the XBox.

Good advice, thanks, but it’s an extremely-used Xbox 360 that my pot-smoking buddy gave me simply because it was collecting dust in his closet. I only use it to play decade-old games. I’m too [del]cheap[/del] broke to buy a current-gen platform system.