Router problem?

I have a dlink wireless router connected to my Hughes.net modem. A desk top is also connected to the modem. It’s hardwired through the router.

I get a green light on the router for a connection to the desktop, and a green light for broadcasting. The internet light (I assume that’s what it is. It’s a globe) is orange.

I get no internet connection either on the desktop, or on wireless devices. But the computers show they are connected to the router.

If I plug the modem directly into the desk top, the internet is fine.

I have rebooted and reset computers, modem and router a number of times.

So, I guess my router is toast?

Your ISP may only accept a DHCP request from a specific registered MAC address, which is a unique hardware identifier for a network device. This is an increasingly rare situation, but it would cause the symptoms you see. Most routers have the ability to detect and clone the MAC address of a particular computer. Connect to your router’s administration page from the desktop and use the appropriate option in your router’s config page.

Otherwise, contact your ISP and ask them if it is necessary to update the registered MAC address for your account.

I connected to my routers admin page and it is able to clone the MAC add from the computer.

I worked with my ISP on this, and all they could tell me was that the modem was working fine.

I reinstalled the drivers for the router, and will try again. The manual for the D-link router is a bit confusing. In one place, it tells me to refer to the manual. Um… I already am. I am now downloading the manual for the modem. Maybe that’s what they meant.

This was working for years.

I meant to say in my OP that this set up had worked for about 3 years. I made no network changes and it went down.

Bump. Still trying to figure this out.

What I still don’t understand is why does my modem get the internet just fine if I wire the modem directly to the desktop. But if I wire the modem to the router and then the router to desktop it fails.

I have internet connectivity through the modem. But if I plug the modem into the router, the router says I have no internet connectivity. This set up worked fine for a couple of years.

So. The router has failed? I don’t get why it’s saying I don’t have internet connectivity when I clearly do (at least at the modem).

Despite being fairly low-maintenance overall, routers do eventually fail. My last Dlink router failed in a very similar manner, with the lights lying to me as I was clearly not getting a connection. How old is the router?

Related older thread: http://boards.straightdope.com/sdmb/showthread.php?t=652523

Fact is that routers fail very often. My personal record was a Netgear router lasting 3 years and now that I think of it, for about one year it was left unused so make that 2 years.

Whenever in the past I had weird and inexplicable network problems the culprit was always the router.

I just had to replace a 3-year old DLink router which was dropping the internet, although my modem was providing it just fine. New router fixed the problem. This time I picked a dual channel Cisco model and am very pleased with the performance, especially wireless.

It was the router. I bought a new one and all is good. Just wanted to thank everyone that responded to the thread.