Safari 5.1.7 questions

After seven years I finally broke down and bought a new computer. Now I have to learn the quirks of new software.

When I open Safari 5.1.7, it opens to the last page I visited. I want it to open to my homepage. In Preferences, I have New windows open with: Homepage. The URL for the homepage is set in Homepage:. New windows do open to the homepage, but I get the last page visited when I first start Safari. How do I get Safari to open to my homepage?

When I click on the Bookmarks tab, I don’t get the Bookmarks Menu. I haven’t saved pages to the Menu proper, but I’ve saved some folders to it and have bookmarked a page in one of them. On the old computer I’d save to Menu and the link would be there when I click the Bookmarks tab. On the new one I have to click Bookmarks|Show all bookmarks. How do I get a list of links when I click on the Bookmarks tab?

I tried entering chflags nohidden ~/Library/ in Terminal, but there was no change.

I think the first behavior you are seeing is Lion loading the last page you visited.
You can change that behavior here: http://osxdaily.com/2011/07/31/disable-resume-specific-applications-mac-os-x-lion/

Move your bookmark to the bookmarks menu.

Didn’t work. I didn’t delete the contents of the apps folder, because I can’t find ‘apps’ when I search in Finder, and the page didn’t give any instructions on what to do. In any case, I closed Safari and then re-started it and both Safari windows I’d been in opened.

Moving my folders into Bookmarks worked. But why the extra step? Why not just be able to save a bookmark to the bookmark menu, rather than having to save it and then move it? :confused:

When you do an “Add Bookmark…” you get the choice of where to save it. Just save it to the menu.
One step.

OK, it’s working now.

On the other matter:

[quote]
If manually deleting specific apps saved Resume states is too tedious for you, you can always choose to just disable the Resume and App Restore feature completely in Mac OS X 10.7.
[ul][li]Launch System Preferences and click on the “General” icon[/li][li]At the bottom of the “Number of recent items” list, uncheck the checkbox next to “Restore windows when quitting and re-opening apps”[/ul][/li][/quote]

I tried this, and Safari still opens previous windows on relaunch.

OK, I think I got it…

I went to ~/Library/Saved Application State/ and moved the Safari folder to the trash. This seemed to have worked.

OK, another question: Exposé does not seem to work the way it does on my PowerBook G4. On the old machine, I can hit a corner to display all windows. On the new machine, it only shows some of the windows when I hit the corner. For example, I still have the Finder window open for the ‘saved state’ folders, and I have one Safari window open. When I hit the corner the Safari window is displayed, but the Finder window isn’t. Is there a way to make Lion show all open windows?

Exposé has changed a lot - it’s now integrated in with Spaces.
On my MacBook, I get little “stacks” of windows for each application. I can select which window I want from the stack.
Play around with the F9 & F10 and see if one of their behaviors is what you want.

F9 doesn’t seem to do anything. F10 opens a window that allows me to change sounds. I’ve just found a page that says you can’t display all windows anymore. Which is a bit of a pain, sine I’m installing new software and can’t get to the window unless I hide Safari.

Hold the Function key down…
The default behavior is for those keys to be dedicated to UI stuff now.

fn+F9 and fn+F10 don’t seem to do anything.

Look in System Preferences-> Mission Control and see what your keyboard shortcuts are set to.

Those appear to be unassigned. But from what I can see elsewhere, it’s not possible to display all windows anymore.