Setting Opera as my default broswers under Win XP?

I’ve checked the box to have Opera check to see if it’s the default browser and rebooted, but IE still starts when I click the email link in MSN and other applications that launch a browser. What am I missing here? I just started using Opera, and I like it. How can I make IE go away unless I specifically open it?

Delete IE?



  1. Click on My Computer
  2. Select [ Tools | Folder Options ]
  3. Select File Types Tab
  4. Go through and change all file type references from IE to Opera

That’s WAY too much work. :smiley:

There has to be an easier way. You can make IE the default without batting an eye. Doesn’t Opera have something to make it that easy?

Here’s a quick and dirty. Go to C:\Windows\inf\sysoc.inf. Open it with Notepad and delete the word “hide” in each line. Save it and then right click it and choose “Install” from the context menu. Then go into your Control Panel\Add Remove Programs\Windows Components and uncheck Internet Explorer. Opera will automatically become your default. You can also see and get rid of some of that other annoying crap.

Well, no. As I alluded to in the OP, I don’t want to completely remove IE. I still prefer it for some websites, like Yahoo! Games.

I had no trouble at all with just letting Opera claim default browser status. I don’t guess the problem is something strange they do at the MSN site?

It’s Microsoft, so anything is possible.

The trouble is Opera doesn’t appear to want default browser status. As I said, I checked to have Opera check to see if it’s the default browser. When it restarts, it’s supposed to say “Opera is not your default browser. Would you like to set it to be” or something like that. But it doesn’t.

Here’s what you need to do:
Open Opera Select ‘File,’ then select ‘Preferences,’ select ‘Default Browser’ then fill in the check boxes you want to have associated with Opera. On mine, under ‘File Types’ I have *.htm and *.html checked, under ‘Protocols’ I have http and https selected. Click ‘apply’ and you’re done.

Now, you know that’s the very first thing I did, [bTuckerfan**. It still doesn’t work when I click the email link in MSN messenger, or click Windows Update, or anything else in Windows that launches a browser. It works fine if I doubleclick a cached page or other associated web document. It’s no biggie, I guess. Apparently Windows feels compelled to use IE for it’s own use.

Ah, okay. If you’re trying to use a Microsoft program, then it’ll go for IE, every time, no matter what settings you change (and if you delete IE, it’ll probably get cranky and tell you there’s nothing it can do since you don’t have IE installed). Any non-Microsoft program should launch Opera. You might try posting over at the Opera message board (it’s free) to see if anyone there has figured out a workaround for this.

Yeah, that figures. Use of IE is probably hard-coded into all Microsoft apps that need a browser. I’ll check out Opera’s board, maybe there is a solution; if anything, it’ll be a registry hack, I’d bet. Thanks everyone, for the responses.

Which version of Windows are you running Q.E.D.?

If your running 98/98SE/ME then I recommend 98lite. It’s free for the individual user. If your running XP like me then your outta luck (like me :().

I’m sorry but I don’t know of any way other then removing IE altogether. The only alternative I know of is to try what Read_Neck said.

BTW Read_Neck, what version does your little trick work for? If it’s XP then I’ll have to try it on my computer.

Keep in mind that Microsoft deliberately changed its web site for a while to deny Opera users access to the site. Of course, M$ denied the charges. Read about it at

XP. Read_Neck’s trick will only remove IE altogether, so any apps that explicitly try to call it will fail at that point.

“sysoc.inf” is in XP. I’m using Pro but it’ll probably be the same in the Home addition. All it does is make IE and some other things visible in Windows Components just as they did in 98. It’s a little strange hiding system settings in an inf. Be sure to Install it. (Right click)

Have you tried changing it by using the Set Program Access and Defaults section in Add/Remove Programs? If you expand the Custom heading there should* be an entry for Opera under Choose a default web browser.

Also, have you unchecked Internet Explorer should check to see whether it is the default browser on the Programs tab of Internet Options?
*In theory anyway. Microsoft added this applet in SP1 due to pressure from the Justice Department, and I doubt they worked very hard on getting all the bugs out.

Ahhh, I thought you meant clicking a link from the MSN web site. If you’re using an MS application like MSN Messenger, it has the ability to either launch a URL using Windows defaults, or it can start IE. Apparently it starts IE. Windows Update does that too.

However, the Windows OS should still launch Opera for a URL. What happens if you click Start, Run, enter “” and hit OK? It should use Opera, right?

Here’s an annoyance I ran across recently. XP told me that it had recovered from a “serious” error, and gave me the option to report it. It then told me that there was more information available about that error by clicking the link it gave. When I clicked the link, it fired up that web page in Opera, but the Microsoft web site told me that I had to use IE to view the page. I had to go back and trap the URL before it forwarded to the non-supported browser page, copy that, and then paste it into IE.

If you are so inclined you can check out Trillian which is an alternative to using MSN and other chat programs (you have probably heard of it). You can use your other chat programs’ user names and logins you just don’t use the actualy programs themselves (MSN and Yahoo will also show mail alerts for you).

Anyway, this won’t solve your IE problem completely but it might solve the Messenger part of it since it’s not a MS product.

Oh yeah, it works just fine for URLs, but any “click to do web stuff”-type button in an MS app launches IE. This is the first time I’ve used a browser other than IE regularly, and I was under the (apparently mistaken) assumption that default browser meant just that.

Opera has a feature (under Preferences > Network) to change the browser identification. I have mine set to MSIE 6.0. I don’t know if that will fool the MS website or not.