Strange problem with software DVD

(Background: Lenovo ThinkPad R61i running WinXP service pack 3)
So I’m trying to upgrade from Microsoft VisualStudio 2005 to the 2008 version. I ordered the upgrade from Provantage. It arrived - in a somewhat curious plastic package - and looked fine. But when I inserted the main DVD into my computer’s DVD drive and tried to inspect it with WindowsExplorer, my system “locked up”: WindowsExplorer stopped responding; when I tried to close it I got the “Program not responding - kill it?” message; when I kill it, I’m hung on a blank screen that looks like my desktop, but with all icons removed (mouse still moved the cursor, but nothing was available to click). Only escape wss a “hard” reboot (i.e. hold down the On button for 5+ seconds).

Note that every other DVD I’ve every tried has behaved exactly as it should.

I took this up with Microsoft and they suggested the DVD might be bad. Provantage was willing to send me a replacement copy (took a surprising time - but that’s another story*) which arrived today. The new DVD does exactly what the old one did.

My next step is to try this DVD on another PC (should be able to do that tomorrow). But what the heck can be causing this?

  • Partial transcript of phone call to Provantage customer support:

PV: Can I have your order number?
Me: It’s 123-4567.
PV: [sound of keyboard] Ah, yes - here it is. So - what’s the status of this order?
Me: [after short puzzled pause] The status is that the customer is on the phone with Provantage Customer Support trying to find out what the status is - earnestly hoping they know more about this than he does.

It can only be a problem with the DVD, your DVD drive, or both. My bet’s on the first - they have a bad batch. You may find it still can’t be read in anther DVD drive but doesn’t cause such a dramatic symptom, due to DVD drive differences.

BTW check your laptop for dust; the DVD drive obviously, but all vents and ports, the keyboard, etc.

I recently inserted a badly burned DVD into a drive and it did exactly the same. I would definitely pin it to the DVD itself as the culprit.

DVD drives can be had for under $20 now a days. Pick one up and see if it works. If it does, great, if it doesn’t then it’s most certainly the DVD, in which case you can return the DVD drive and think of the few bucks you’ll lose in restocking fees as a rental fee.
I got my copy of VS2K8 online. If you already have a licence, try downloading the online version form the microsoft website and using your key.

Thanks - will definitely try another DVD drive.

Would there be any way to use the license from the version I bought (but seem unable to install)?

What’s your view of VS2008? Worth the trouble?

My PC is kinda marginal based on the minimum specs for VS2008 - is that likely to be a problem?

If you can read it on another PC, maybe you could burn a copy of it, and install from that. I was able to do this with a flawed CD one time.

Follow-up. I was able to read this on a friend’s PC. I then copied it via a network connection and installed it from the copy on my hard drive - no problem.

I have no idea why one and only one DVD would not only be unreadable, but also render my PC non-functional.

Many thanks for helpful suggestions.

VS2008 is a resource hog. I had to go from 1 to 2 GB RAM to run it with a reasonable performance.

I can save you rebooting.

Ctrl, Alt + Del. Applications tab, highlight app, end task.