Taskbar Question

I’m running Win XP SP2 as the OS. I double-click on a certain program on the desktop and it opens. But it only shows as a running app on the taskbar and in Task Manager. However, it won’t show the program on the screen itself. Any ideas?
I tried opening up other apps and no problems.

What happens if you try to Alt-Tab into the program?

I tried alt-tabbing between the problem program and three other open apps, and the one damn prog refuses to open on the screen but the others will open on the screen. Frustrating.

Click on the program in the taskbar, and then push Alt+Space, let go, and push R. This “Restores” the window if it was in some bizarre minimized state. See if that makes it show up. If not, push Alt-Space again, let go, and push M. This lets you Move it around with the arrow keys and sometimes that can bring things back into view. The move cursor should appear where the window actually is, and based on that you can hopefully navigate it back to the center of the screen.

(Sometimes programs get shifted off-screen for random reasons such as resolution changes, etc… this may or may not be the cause here, but it’s worth a try.)

I’ve had this happen where the program didn’t show up. Had to get into the task manager, click the Processes tab and close it from there. Then reopen it. Sometimes there is a process running that is part of the program so the program won’t open. A reboot should fix both of these problems.

Two things to do:

  1. Check that the shortcut is not set to start the app minimised.

  2. Run the app and let it go to the startbar. Open any other window - I normally use Explorer or Notepad - then right-click the taskbar and select Cascade Windows. Then close the app. This covers two issues: that of the app being off-screen, and of being minimised due to a registry issue.

Alternatively, right-click on the program in the taskbar. This does the same thing and will display the same menu. Then select restore or maximize or size.

I have a related problem. If I schedule a task that wakes up the PC from hibernate to start RealPlayer, something like what the OP describes happens when it runs. If I log in while it’s running, it won’t display. Selecting restore from the taskbar doesn’t work. I have to select maximize, and the player displays in a “restore” size, but I can’t move or resize it. If I click on the restore icon in the upper right, then I can resize and/or move the player.